Introduction

ArchiveManager, formerly DIET, is a powerful archiving application for ClarifyCRM databases. It has the high performance and easy management required by large mission critical ClarifyCRM environments. ArchiveManager augments the feature set of the base-line tools provided in Clarify with a variety of features that enable much greater agility in moving large amounts of complex data. It provides the fundamental performance and stability required by administrators working to keep their Clarify systems in peak condition as corporations continue to expand the scope and complexity of their customer data.

With ArchiveManager, you can:

  • Purge – Remove data from your ClarifyCRM database.
  • Archive – Store data for later use.
  • Import – Import archived data to your ClarifyCRM database.
  • Export – Export data in an archive file syntax that is backwards compatible with Clarify's Dataex product.

Benefits of conducting regular purge and archive operations include:

  • Better CRM system responsiveness.
  • Reduced hardware costs.
  • Shorter backup times, and most importantly, shorter disaster recovery times.
  • More manageable database replication for high availability.

Features

  • Full object support - Archive any custom or standard ClarifyCRM object.
  • Advanced selection interface - Select data for archival based on virtually any criteria.
  • Easy installation and low administrative overhead - A basic ArchiveManager installation can be completed in a matter of minutes and it is ideally suited for scripted batch processing for long term database maintenance.
  • Automated configuration - ArchiveManager systematically identifies custom objects in the database and automatically completes needed configurations to handle them properly. It minimizes the installation effort even for highly customized Clarify systems as well as enabling easier administration as new customizations are added over time.
  • Automated index analysis and creation - Optionally analyzes existing indices and creates new ones as necessary for maximum performance.
  • Recovery Mode - Keeps track of its progress so that in the event of an interruption, processing can restart at the point of interruption.
  • Data Restore UI - Archived data can easily be restored in single or multiple record increments.
  • Dataex emulation - Responds to all Dataex commands and can be installed as a complete replacement of Dataex.
  • Broad platform support - Available to run on MS Windows, Sun Solaris, HP-UX. Supports Oracle and SQL Server, and all Clarify versions 7.0 or later.
  • DART included - DART, the Data Archive Restoration/Viewing Tool, is also included with ArchiveManager. With DART, you can sort, filter, report, view, and restore archived objects from within Clarify. For more information about DART, please view the DART documentation.

In This Chapter

Getting Help

Next

Getting Help
Introduction

Did this topic help you? Email us your feedback.
Last updated: 12/13/2007 4:52:31 PM
© by Dovetail Software, Inc.


Getting Help

If you need additional help beyond this user guide, you can use any of the following resources:

  • Dovetail SelfService - Use our online customer support site to notify us of a support issue, to manage your Dovetail products, to seek sales support, or to search the knowledge base.
  • Knowledge Base Articles - Search our online knowledge base for existing issue resolutions.
  • Product Documentation - Find Dovetail's most up-to-date product documentation.
  • Blog Posts - Dovetail developers often publish useful posts about ArchiveManager
  • Contact Us - Contact us directly if you need further assistance.
    • support@dovetailsoftware.com
    • phone 800-684-2055 or 512-610-5400

See Also

Introduction

Next

Requirements
Getting Help

Did this topic help you? Email us your feedback.
Last updated: 1/5/2011 5:07:18 PM


Requirements

Operating System

Microsoft Windows

  • Server 2003
  • Server 2008
  • Windows 7
  • XP Professional SP3

Database platforms
  • Microsoft SQL Server (2000, 2005, 2008)

Note:

ArchiveManager version 2.3 is supported only with Microsoft SQL Server databases.

Previous versions (up to 2.2.1) do support Oracle databases.

It is planned that the next version of ArchiveManager will include support for Oracle.

If this is a need for your organization, please contact Dovetail Software.

Clarify / Amdocs
  • Clarify 7 through Clarify 12.x
  • Amdocs 6.x
  • Amdocs 7.x

Next

New Features
Requirements

Did this topic help you? Email us your feedback.
Last updated: 10/4/2011 3:38:00 PM


New Features

This section describes what's new in each ArchiveManager release.

In This Chapter

Version 2.3

Version 2.2.1

Version 2.2

Version 1.1.2

Version 2.1.12

Version 2.1.11

Version 2.1.10

Version 2.1.9

Version 2.1.8

Version 2.1.7

Version 2.1.6

Version 2.1.5

Version 2.1.4

Version 2.1.3

Version 2.1.2

Version 2.1.1

Version 2.1

Version 2.0

Version 1.1.4

Version 1.1.3

Version 1.1.1

Version 1.1.0

Version 1.0.13

Version 1.0.11

Version 1.0.10

Version 1.0.9

Version 1.0.12

Next

Version 2.3
New Features

Did this topic help you? Email us your feedback.
Last updated: 11/6/2007 10:20:44 AM


Version 2.3

Enhancements

  • Added support for Unicode characters. Requires the Clarify database to be unicode enabled.
  • If an SQL statement generated by ArchiveManager returns an error resulting in "Error in basic query" message being written to the log file, this message is now elevated to ERROR category and all information necessary for debugging: RDBMS-returned description and the SQL statement itself are also written to the log file.

Behavior Changes

  • In a purge/archive operation, null and default fields are not written to the export file by default.
    To include NULL values, and defaults (such as empty strings) in the archive file, use the -expdef option.
    Refer to the Purge/Archive Command Parameters topic for more information on the -expdef option.

Bug Fixes

  • Fixed a problem with missing objects in export file occurring when a parent object is skipped due to STOP_IF clause condition being true. For example, a directive file calls for export of cases and related contacts. Before the fix, if two cases, A and B, are related to the came contact C, and case A is exported first but skipped because of a STOP_IF clause, the common contact C would have been considered as already exported for the sake of case B. The export file would not contain the contact C information, however, causing an error on import. The fix makes sure that skipping of case A removes contact C from the list of exported objects resulting in proper export of case B and its dependent objects.

Database Platform Support

ArchiveManager version 2.3 is supported only with Microsoft SQL Server databases. Previous versions (up to 2.2.1) do support Oracle databases. It is planned that the next version of ArchiveManager will include support for Oracle. If this is a need for your organization, please contact Dovetail Software.

Next

Version 2.2.1
Version 2.3

Did this topic help you? Email us your feedback.
Last updated: 10/4/2011 3:37:15 PM


Version 2.2.1

Bug Fixes

  • Fixed an issue involving descending order indexes.
    If a descending order index was present, ArchiveManager would throw a fatal error, such as: Can not find unique field or relation 'creation_time(-)'
    This was due to the "(-)" characters at the end of the column name when ArchiveManager was retrieving the indexes (and the columns defined in that index) using sp_helpindex.
    This only applies to Microsoft SQL Server databases. This issue has been resolved.

Next

Version 2.2
Version 2.2.1

Did this topic help you? Email us your feedback.
Last updated: 7/22/2010 1:28:05 PM


Version 2.2

Enhancements

  • The maximum number of relations allowed per table has been expanded from 256 to 1024

Clarify/Amdocs Support

  • This version adds support for Amdocs 7.x systems

Platform Support

  • This version is supported only on Windows platforms. The database itself can be on any platform, but ArchiveManager must be executed on Windows.
  • If different platform support is needed, please contact Dovetail Software.

See Also

New Features

Version 2.3

Version 2.2.1

Version 1.1.2

Version 2.1.12

Version 2.1.11

Version 2.1.10

Version 2.1.9

Version 2.1.8

Version 2.1.7

Version 2.1.6

Version 2.1.5

Version 2.1.4

Version 2.1.3

Version 2.1.2

Version 2.1.1

Version 2.1

Version 2.0

Version 1.1.4

Version 1.1.3

Version 1.1.1

Version 1.1.0

Version 1.0.13

Version 1.0.11

Version 1.0.10

Version 1.0.9

Version 1.0.12

Next

Version 1.1.2
Version 2.2

Did this topic help you? Email us your feedback.
Last updated: 12/2/2009 2:16:03 PM


Version 1.1.2

Enhancements

  • Made import unspecified relations as default.

Bug Fixes

  • Fixed Oracle problems with reading very long fields.
  • Fixed Oracle problems with buffer on long fields.
  • Fixed Oracle problem with date formatting on long dates.
  • Fixed detection of unspecified forward references in purge format.
  • Fixed parsing error internal to comments.
  • Correct debug now prints to log_file, not stderr.

See Also

New Features

Version 2.3

Version 2.2.1

Version 2.2

Version 2.1.12

Version 2.1.11

Version 2.1.10

Version 2.1.9

Version 2.1.8

Version 2.1.7

Version 2.1.6

Version 2.1.5

Version 2.1.4

Version 2.1.3

Version 2.1.2

Version 2.1.1

Version 2.1

Version 2.0

Version 1.1.4

Version 1.1.3

Version 1.1.1

Version 1.1.0

Version 1.0.13

Version 1.0.11

Version 1.0.10

Version 1.0.9

Version 1.0.12

Next

Version 2.1.12
Version 1.1.2

Did this topic help you? Email us your feedback.
Last updated: 7/27/2007 3:17:51 PM


Version 2.1.12

Bug Fixes

  • Fixed reading and updating NULL values for LOB types in Oracle

See Also

New Features

Version 2.3

Version 2.2.1

Version 2.2

Version 1.1.2

Version 2.1.11

Version 2.1.10

Version 2.1.9

Version 2.1.8

Version 2.1.7

Version 2.1.6

Version 2.1.5

Version 2.1.4

Version 2.1.3

Version 2.1.2

Version 2.1.1

Version 2.1

Version 2.0

Version 1.1.4

Version 1.1.3

Version 1.1.1

Version 1.1.0

Version 1.0.13

Version 1.0.11

Version 1.0.10

Version 1.0.9

Version 1.0.12

Next

Version 2.1.11
Version 2.1.12

Did this topic help you? Email us your feedback.
Last updated: 11/18/2008 9:44:02 AM


Version 2.1.11

Enhancements

  • Delete failures that occur during an import are now reported as warnings instead of errors.

Bug Fixes

  • Searchable items now match interpretation in Dovetail SchemaEditor

See Also

New Features

Version 2.3

Version 2.2.1

Version 2.2

Version 1.1.2

Version 2.1.12

Version 2.1.10

Version 2.1.9

Version 2.1.8

Version 2.1.7

Version 2.1.6

Version 2.1.5

Version 2.1.4

Version 2.1.3

Version 2.1.2

Version 2.1.1

Version 2.1

Version 2.0

Version 1.1.4

Version 1.1.3

Version 1.1.1

Version 1.1.0

Version 1.0.13

Version 1.0.11

Version 1.0.10

Version 1.0.9

Version 1.0.12

Next

Version 2.1.10
Version 2.1.11

Did this topic help you? Email us your feedback.
Last updated: 11/18/2008 9:28:54 AM


Version 2.1.10

Enhancements

  • Improved generate through unique relations of object.
  • Added –delete_only parameter for generate.

Bug Fixes

  • When an object has exclusive relations, it is no longer a problem to delete the import object or purge with the –thorough command parameter.
  • Fixed problem with searching objects with null relations.

See Also

New Features

Version 2.3

Version 2.2.1

Version 2.2

Version 1.1.2

Version 2.1.12

Version 2.1.11

Version 2.1.9

Version 2.1.8

Version 2.1.7

Version 2.1.6

Version 2.1.5

Version 2.1.4

Version 2.1.3

Version 2.1.2

Version 2.1.1

Version 2.1

Version 2.0

Version 1.1.4

Version 1.1.3

Version 1.1.1

Version 1.1.0

Version 1.0.13

Version 1.0.11

Version 1.0.10

Version 1.0.9

Version 1.0.12

Next

Version 2.1.9
Version 2.1.10

Did this topic help you? Email us your feedback.
Last updated: 7/27/2007 2:57:12 PM


Version 2.1.9

  • Added Clarify 13 support.

See Also

New Features

Version 2.3

Version 2.2.1

Version 2.2

Version 1.1.2

Version 2.1.12

Version 2.1.11

Version 2.1.10

Version 2.1.8

Version 2.1.7

Version 2.1.6

Version 2.1.5

Version 2.1.4

Version 2.1.3

Version 2.1.2

Version 2.1.1

Version 2.1

Version 2.0

Version 1.1.4

Version 1.1.3

Version 1.1.1

Version 1.1.0

Version 1.0.13

Version 1.0.11

Version 1.0.10

Version 1.0.9

Version 1.0.12

Next

Version 2.1.8
Version 2.1.9

Did this topic help you? Email us your feedback.
Last updated: 7/27/2007 2:57:28 PM


Version 2.1.8

Enhancements

  • Created NT/Sybase compilation.
  • Added ability to set fields to NULL and to the default value.
  • Added check that adp_tbl_oid is filled for Oracle.
  • Added explicit date formatting at writes to avoid internal Oracle error.
  • Improved ArchiveManager on Oracle for multiple connections.
  • Improved verification writes now happen before a commit.
  • Added code to allow using an exclusive relation as a unique key.
  • Validated objid fields of exclusive relations use the REFERENCE keyword. That reference is an object of the proper type of the exclusive relation.
  • Validated objid fields of exclusive relations use the TABLE keyword. That table is pointed to by the exclusive relation.
  • Improved writing of exclusive relations in archive/purge output.

Bug Fixes

  • Fixed error message for row count error.
  • Fixed fields used as references to work as 64 bit references.
  • Fixed lookup of object with a reference field when the reference is a forward reference.
  • Fixed reading and storage of reference which used exclusive relation as part of unique key.
  • Fixed problems when indexes exist in databases on Clarify tables but do not contain Clarify fields.
  • Fixed problem with extra backslashes added on output lines.

See Also

New Features

Version 2.3

Version 2.2.1

Version 2.2

Version 1.1.2

Version 2.1.12

Version 2.1.11

Version 2.1.10

Version 2.1.9

Version 2.1.7

Version 2.1.6

Version 2.1.5

Version 2.1.4

Version 2.1.3

Version 2.1.2

Version 2.1.1

Version 2.1

Version 2.0

Version 1.1.4

Version 1.1.3

Version 1.1.1

Version 1.1.0

Version 1.0.13

Version 1.0.11

Version 1.0.10

Version 1.0.9

Version 1.0.12

Next

Version 2.1.7
Version 2.1.8

Did this topic help you? Email us your feedback.
Last updated: 8/1/2007 9:25:21 AM


Version 2.1.7

Enhancements

  • Improved performance on Oracle 8.1.6 and after.
  • Improved and sped up method for getting row counts.
  • Added –unused parameter use in the unused objid table. Behavior change: Previously, the unused objid table was always used. Now, the –unused parameter must be explicitly used to avoid possible failures in locking updates.
  • Improved batch object fetching in purge archive when many objects are requested at once from the same table.

Bug Fixes

  • Fixed problem with parsing strings in where clauses.
  • Fixed locking problem with unused objid table on Oracle.

See Also

New Features

Version 2.3

Version 2.2.1

Version 2.2

Version 1.1.2

Version 2.1.12

Version 2.1.11

Version 2.1.10

Version 2.1.9

Version 2.1.8

Version 2.1.6

Version 2.1.5

Version 2.1.4

Version 2.1.3

Version 2.1.2

Version 2.1.1

Version 2.1

Version 2.0

Version 1.1.4

Version 1.1.3

Version 1.1.1

Version 1.1.0

Version 1.0.13

Version 1.0.11

Version 1.0.10

Version 1.0.9

Version 1.0.12

Next

Version 2.1.6
Version 2.1.7

Did this topic help you? Email us your feedback.
Last updated: 7/27/2007 3:08:02 PM


Version 2.1.6

Enhancements

  • Enhanced import and purge speeds, which in some cases speeds up the import by a factor of 40.
  • Enhanced index_analyze to report the ArchiveManager indexes that already exist in the database.
  • Added functionality to clear relations for already existing objects.
  • Instead of just fatal errors, all errors now go to stderr.
  • A valid license is not required to generate new DART indexes for existing archives.

Bug Fixes

  • Fixed problem in index files that results when the title and other fields have new lines.

See Also

New Features

Version 2.3

Version 2.2.1

Version 2.2

Version 1.1.2

Version 2.1.12

Version 2.1.11

Version 2.1.10

Version 2.1.9

Version 2.1.8

Version 2.1.7

Version 2.1.5

Version 2.1.4

Version 2.1.3

Version 2.1.2

Version 2.1.1

Version 2.1

Version 2.0

Version 1.1.4

Version 1.1.3

Version 1.1.1

Version 1.1.0

Version 1.0.13

Version 1.0.11

Version 1.0.10

Version 1.0.9

Version 1.0.12

Next

Version 2.1.5
Version 2.1.6

Did this topic help you? Email us your feedback.
Last updated: 8/1/2007 9:25:22 AM


Version 2.1.5

Enhancements

  • Added error message in Oracle versions that do not support clobs when the clob code is accessed.
  • Made purge change any unwritten references to exports when they are encountered as an export in a purge.
  • Corrected Oracle to not assume that objid is the default index when no other index is specified.
  • Made Fatal errors show up on stderr when they are reported to the logfile.
  • Exposed internal timer code (-timer).
  • Removed Notice counting when silent notices are output.

Bug Fixes

  • Fixed problem in 2.1.2 patcher program, which is only needed for upgrades from 2.1.2 ArchiveManager.
  • Fixed problem with If/Then/Else purging introduced in 2.1.4
  • Corrected problem with discovering unique index when purging through a field.
  • Corrected problem with pipe character in the Dart index files and made it configurable (-esplit).

See Also

New Features

Version 2.3

Version 2.2.1

Version 2.2

Version 1.1.2

Version 2.1.12

Version 2.1.11

Version 2.1.10

Version 2.1.9

Version 2.1.8

Version 2.1.7

Version 2.1.6

Version 2.1.4

Version 2.1.3

Version 2.1.2

Version 2.1.1

Version 2.1

Version 2.0

Version 1.1.4

Version 1.1.3

Version 1.1.1

Version 1.1.0

Version 1.0.13

Version 1.0.11

Version 1.0.10

Version 1.0.9

Version 1.0.12

Next

Version 2.1.4
Version 2.1.5

Did this topic help you? Email us your feedback.
Last updated: 8/1/2007 9:25:25 AM


Version 2.1.4

Enhancements

  • Improved long text data handling.
  • Enhanced to allow multiple long text fields in Oracle databases.
  • Enhanced to allow exclusive and pseudo-exclusive relations to be purged and imported. Also added code in no_gen to generate exclusive relation purging.
  • Added ability to do conditional purging. Behavior change: There is no longer special support for participant archiving, because that is a case of exclusive relations.
  • Enhanced so that null fields can be used as unique fields.
  • Added ability to allow null relations to be part of a unique key (-allow_null parameter).
  • Added an ability to specify certain relations as null for imports.
  • Enhanced –log and –mess to create a time stamped log file name when no log file name is supplied.
  • Enhanced message and log file handling so that message file and log file can be the same file.
  • Enhanced to allow an Oracle 8i version of ArchiveManager to connect to an Oracle 9i database.
  • Enhanced to allow comments in the .env file.
  • Improved stop_if ability.
  • Enhanced so that the database is queried less.
  • Edited supplied case.arc to demonstrate how to archive all closed_cases.

Bug Fixes

  • Fixed an occasional purging problem, so that the objid is no longer generated as a unique key when –objid is not specified.
  • Fixed problem when the Clarify internal adp tables are out of order.
  • Corrected errors in eindex where required fields are null.
  • Fixed problems when Clarify treats an OTO relation as an MTO relation.
  • Corrected problem when recursively purging with a stop_if.
  • Fixed problem with binary data fields on Oracle.

See Also

New Features

Version 2.3

Version 2.2.1

Version 2.2

Version 1.1.2

Version 2.1.12

Version 2.1.11

Version 2.1.10

Version 2.1.9

Version 2.1.8

Version 2.1.7

Version 2.1.6

Version 2.1.5

Version 2.1.3

Version 2.1.2

Version 2.1.1

Version 2.1

Version 2.0

Version 1.1.4

Version 1.1.3

Version 1.1.1

Version 1.1.0

Version 1.0.13

Version 1.0.11

Version 1.0.10

Version 1.0.9

Version 1.0.12

Next

Version 2.1.3
Version 2.1.4

Did this topic help you? Email us your feedback.
Last updated: 8/1/2007 9:25:27 AM


Version 2.1.3

Enhancements

  • Added a patch utility to fix archive files generated with 2.1.2. For more information, see the Bug Fix note below.
  • Modified case of field names in output to allow reimportation with Dataex.
  • Added code to handle problem when objid on table is NULL (a Clarify violation).

Bug Fixes

  • Fixed the 2.1.2 bug that occurred when purging and archiving with references using multiple unique fields.
  • The iterative status update is now always sent to the screen.

See Also

New Features

Version 2.3

Version 2.2.1

Version 2.2

Version 1.1.2

Version 2.1.12

Version 2.1.11

Version 2.1.10

Version 2.1.9

Version 2.1.8

Version 2.1.7

Version 2.1.6

Version 2.1.5

Version 2.1.4

Version 2.1.2

Version 2.1.1

Version 2.1

Version 2.0

Version 1.1.4

Version 1.1.3

Version 1.1.1

Version 1.1.0

Version 1.0.13

Version 1.0.11

Version 1.0.10

Version 1.0.9

Version 1.0.12

Next

Version 2.1.2
Version 2.1.3

Did this topic help you? Email us your feedback.
Last updated: 8/1/2007 9:27:58 AM


Version 2.1.2

Enhancements

  • Added support for Clarify 12.
  • Added Clarify 12.0 Dataex keyword to import (not to be confused with the –insert_only keyword).
  • Removed adb_db_comments write with – index_analyze.
  • Added start/stop times into logs for purge runs.
  • Added iterative status updates during a purge.
  • Added a report of the number of objects skipped.
  • Added –report command parameter.
  • Optimized index creation.
  • Optimized reading of reference in purge/archive.
  • In a purge/archive file, null fields are now outputted by default. Behavior Change: In previous versions, -expdef was required to output these values.
  • Multiple text fields are now supported on a database object.
  • Added index generation on simple where clauses.
  • Improved index analysis so that it ignores existing statistical indexes in MSSQL.
  • Added in parsing of scientific notation in input files.

Bug Fixes

  • Fixed crash on –message_file on HP.
  • Fixed crash on bad stop_if.
  • Fixed crash when purging with the –lite parameter.
  • Fixed crash in OTM specified in p_template file.

See Also

New Features

Version 2.3

Version 2.2.1

Version 2.2

Version 1.1.2

Version 2.1.12

Version 2.1.11

Version 2.1.10

Version 2.1.9

Version 2.1.8

Version 2.1.7

Version 2.1.6

Version 2.1.5

Version 2.1.4

Version 2.1.3

Version 2.1.1

Version 2.1

Version 2.0

Version 1.1.4

Version 1.1.3

Version 1.1.1

Version 1.1.0

Version 1.0.13

Version 1.0.11

Version 1.0.10

Version 1.0.9

Version 1.0.12

Next

Version 2.1.1
Version 2.1.2

Did this topic help you? Email us your feedback.
Last updated: 8/1/2007 9:28:01 AM


Version 2.1.1

Enhancements

  • Improved error messages for –objid and -auto_unique on object generation.
  • Made objid an output only when it's part of unique key.
  • Made archive output object counts.
  • Added –pick_one import parameter.
  • Added -sqllog general parameter.
  • Added –eimport import parameter.
  • The local path file name is now entered in .ind files.
  • Removed extra transactions when restoring only one object.
  • Improved no_gen error messages when generating purge/archive directives files.
  • Index messages no longer appear when using the –no_index parameter.

Bug Fixes

  • Fixed problem in file handling when using the -iterative and -no_write parameters.
  • Fixed bad address handling in the case.no_gen file.
  • Fixed problem with not outputting text fields in no_expdef.
  • Fixed so that checksum is validated on import.
  • Fixed problem with recovery files not being deleted.
  • Fixed problem with –object where references contain references.
  • Fixed problem where extended lines lose their linefeeds.
  • Fixed extra space field in .ind file.

See Also

New Features

Version 2.3

Version 2.2.1

Version 2.2

Version 1.1.2

Version 2.1.12

Version 2.1.11

Version 2.1.10

Version 2.1.9

Version 2.1.8

Version 2.1.7

Version 2.1.6

Version 2.1.5

Version 2.1.4

Version 2.1.3

Version 2.1.2

Version 2.1

Version 2.0

Version 1.1.4

Version 1.1.3

Version 1.1.1

Version 1.1.0

Version 1.0.13

Version 1.0.11

Version 1.0.10

Version 1.0.9

Version 1.0.12

Next

Version 2.1
Version 2.1.1

Did this topic help you? Email us your feedback.
Last updated: 7/27/2007 3:13:10 PM


Version 2.1

Enhancements

  • During a purge or archive, ArchiveManager now deletes each object hierarchy after it is written to the archive file. Behavior Change: In previous versions, object hierarchies were not deleted until all objects had been read and written to the archive file. To revert to the original behavior, use the –no_iterative command parameter.
  • Added Schema_rev keyword to archived output.
  • Added '#' comments to import formats.
  • Improved message log buffering.
  • Made 2 digit dates meet new Dovetail compliance.
  • Added the –y2k parameter.
  • Added –mto parameter so that data can be reimported from semi-corrupt Clarify databases.
  • Added run time to header output.
  • Added header to message log.
  • Improved performance by checking row_count when using the –through parameter.
  • Improved and sped up purging in MTM tables.
  • Iterative purging is now the default.
  • Improved checksum generation.
  • Added improvements to no_gen files to support Stop_ifs, uniques, and comments.
  • Added –eindex. Behavior Change: By default, archive index files are not generated.
  • Added the –mto parameter to reimport corrupted Clarify data.

Bug Fixes

  • Work around created for Oracle 8.1.7 library crash.
  • Fixed critical import error: items with modify timestamps can now be imported.
  • Fixed problem that resulted when mandatory parameters were in both the .env file and the command line.
  • Fixed problem with purging exclusive relations.
  • Fixed problem that caused a crash when –no_recovery and –import_only are specified together.
  • Fixed bad date in .idr files on Oracle.
  • Fixed binary error in .idr on NT.
  • Fixed bug with purging when entry_name2gbst_elm is null.
  • Fixed bug with purging when act_entry2user is null.
  • Fixed stop when index on a non-Clarify field is on a Clarify table.

See Also

New Features

Version 2.3

Version 2.2.1

Version 2.2

Version 1.1.2

Version 2.1.12

Version 2.1.11

Version 2.1.10

Version 2.1.9

Version 2.1.8

Version 2.1.7

Version 2.1.6

Version 2.1.5

Version 2.1.4

Version 2.1.3

Version 2.1.2

Version 2.1.1

Version 2.0

Version 1.1.4

Version 1.1.3

Version 1.1.1

Version 1.1.0

Version 1.0.13

Version 1.0.11

Version 1.0.10

Version 1.0.9

Version 1.0.12

Next

Version 2.0
Version 2.1

Did this topic help you? Email us your feedback.
Last updated: 8/1/2007 9:25:30 AM


Version 2.0

Enhancements

  • The following changes allow ArchiveManager to interface with the new DART product:
    • Added generation of index files for archive files.
    • Added -object parameter to allow selective importation from archives.
    • Added –no_eindex parameter for DART index file creation.
    • Added –p_template parameter to give path to user supplied index template.
  • Added code in import to use objids from unused table.
  • Added -compact to generate compact archive files.
  • Added DATE_FORMAT keyword to import and as part of archive generation.
  • Now allowed to purge through fields like relations (for example, site_objid on object site_part).
  • Added -recycle parameter to allow reuse of purged objids (see warnings in the Purge/Archive Command Syntax section).
  • Added pseudo-header to generated archive file output.
  • It is now easier to install the license.
  • Export now gives a clean error when purge archive is supplied.
  • Now gives a clean error message when file is in the wrong format.
  • Deactivated the -no_delete parameter (duplicates -archive).
  • Improved the internal object control and performance.
  • Improved the no_gen format for –generate.
  • Improved generation with –generate.
  • Now allowed to work with any version of the Clarify internal adp_db_comments table (differing column names).
  • Added –no_write parameter to support purge.
  • Changed checksum to only edit checksum and not purge.
  • Changed default date format from "%d/%m/%Y %H:%M:%S" to "%m/%d/%Y %H:%M:%S"

Bug Fixes

  • Fixed Unique Relation problem that occurred when purging.
  • Unique indexes are now ignored when the objid is one component.
  • Fixed problem that occurred when forward reference is used in a field treated as a relation.
  • Corrected erroneous syntax error on binary data.

See Also

New Features

Version 2.3

Version 2.2.1

Version 2.2

Version 1.1.2

Version 2.1.12

Version 2.1.11

Version 2.1.10

Version 2.1.9

Version 2.1.8

Version 2.1.7

Version 2.1.6

Version 2.1.5

Version 2.1.4

Version 2.1.3

Version 2.1.2

Version 2.1.1

Version 2.1

Version 1.1.4

Version 1.1.3

Version 1.1.1

Version 1.1.0

Version 1.0.13

Version 1.0.11

Version 1.0.10

Version 1.0.9

Version 1.0.12

Next

Version 1.1.4
Version 2.0

Did this topic help you? Email us your feedback.
Last updated: 8/1/2007 9:25:33 AM


Version 1.1.4

Enhancements

  • Added default value for Clarify Float type.

Bug Fixes

  • Fixed error so that the Oracle return string buffer is now NULL terminated.
  • Fixed parsing error in various floating point formats.

See Also

New Features

Version 2.3

Version 2.2.1

Version 2.2

Version 1.1.2

Version 2.1.12

Version 2.1.11

Version 2.1.10

Version 2.1.9

Version 2.1.8

Version 2.1.7

Version 2.1.6

Version 2.1.5

Version 2.1.4

Version 2.1.3

Version 2.1.2

Version 2.1.1

Version 2.1

Version 2.0

Version 1.1.3

Version 1.1.1

Version 1.1.0

Version 1.0.13

Version 1.0.11

Version 1.0.10

Version 1.0.9

Version 1.0.12

Next

Version 1.1.3
Version 1.1.4

Did this topic help you? Email us your feedback.
Last updated: 7/27/2007 3:17:03 PM


Version 1.1.3

Enhancements

  • Added purge index generation on stop_ifs.
  • Added purge index generation on key fields.
  • Added object counts to the end of the archive file.
  • Straightened out and made consistent parameter handling.
  • Added adp_verbose parameter.

Bug Fixes

  • Fixed bug in handling medium sized (>256) user defined fields.
  • Fixed bug in Oracle for regenerating unique ArchiveManager purge index names.
  • Fixed import bug where the last group was sometimes not imported.
  • Fixed errors when using the –recovery parameter while importing.
  • Added no_stopif parameter.

See Also

New Features

Version 2.3

Version 2.2.1

Version 2.2

Version 1.1.2

Version 2.1.12

Version 2.1.11

Version 2.1.10

Version 2.1.9

Version 2.1.8

Version 2.1.7

Version 2.1.6

Version 2.1.5

Version 2.1.4

Version 2.1.3

Version 2.1.2

Version 2.1.1

Version 2.1

Version 2.0

Version 1.1.4

Version 1.1.1

Version 1.1.0

Version 1.0.13

Version 1.0.11

Version 1.0.10

Version 1.0.9

Version 1.0.12

Next

Version 1.1.1
Version 1.1.3

Did this topic help you? Email us your feedback.
Last updated: 8/1/2007 9:25:35 AM


Version 1.1.1

Enhancements

  • Reduced export/archive file size on Oracle.
  • Changed 'No object type set for this routine' from a warning to an error.
  • Added error in purge if –auto_unique and object has no indexes or uniques.
  • Added error in purge post processing if it has an undefined routine.
  • Cleaned up and revised the version header and purge output.
  • The process will end if purge parse post-processing discovers an error.
  • Changed default on import date to ?/?/? ?:?:?

Bug Fixes

  • Fixed outputting searchable unique fields on –auto_unique for Oracle purge and export.
  • Fixed problem purging through MTMs.
  • Fixed problem with reference not putting out relation if in two different purge groups.
  • Fixed crash that occurred when printing an error message on –generate of an object type that doesn't exist.
  • Fixed problem with adp_db_comments on parallel runs.
  • Fixed problems in internal debug parameters (and added one).
  • Fixed to exit gracefully instead of core dump when –generate value is not an object.

See Also

New Features

Version 2.3

Version 2.2.1

Version 2.2

Version 1.1.2

Version 2.1.12

Version 2.1.11

Version 2.1.10

Version 2.1.9

Version 2.1.8

Version 2.1.7

Version 2.1.6

Version 2.1.5

Version 2.1.4

Version 2.1.3

Version 2.1.2

Version 2.1.1

Version 2.1

Version 2.0

Version 1.1.4

Version 1.1.3

Version 1.1.0

Version 1.0.13

Version 1.0.11

Version 1.0.10

Version 1.0.9

Version 1.0.12

Next

Version 1.1.0
Version 1.1.1

Did this topic help you? Email us your feedback.
Last updated: 7/27/2007 3:18:30 PM


Version 1.1.0

Enhancements

  • Added HPUX 11 support.
  • Added support for Clarify 10.
  • Added exclusive relation support (Clarify 9.0).
  • Added participant purging (Clarify 9.0).
  • Added TABLE keyword.
  • Fields are now allowed to be multiply defined if the value is the same.
  • Removed checksum verifications on archive (still done on purge).
  • Made purge message "Unique relation %s used - but no to clause for it exists" a warning instead of an error.
  • Dates are now validated without the 'DATE' specification.
  • Improved purging status report.

Bug Fixes

  • Fixed crash that occurred with extra long fields on Oracle.
  • Fixed import query when the date field is a unique field.
  • Fixed TO= relation with negative objid.
  • Fixed objid allocation when site_id != 1

See Also

New Features

Version 2.3

Version 2.2.1

Version 2.2

Version 1.1.2

Version 2.1.12

Version 2.1.11

Version 2.1.10

Version 2.1.9

Version 2.1.8

Version 2.1.7

Version 2.1.6

Version 2.1.5

Version 2.1.4

Version 2.1.3

Version 2.1.2

Version 2.1.1

Version 2.1

Version 2.0

Version 1.1.4

Version 1.1.3

Version 1.1.1

Version 1.0.13

Version 1.0.11

Version 1.0.10

Version 1.0.9

Version 1.0.12

Next

Version 1.0.13
Version 1.1.0

Did this topic help you? Email us your feedback.
Last updated: 7/27/2007 3:19:00 PM


Version 1.0.13

Enhancements

  • Added Unix/ Sybase support.
  • Added support for new functions in Clarify 9/Oracle.
  • Empty dates are now allowed.

Bug Fixes

  • Fixed bug that occurred when committing a license key when no work is requested.
  • Fixed bug in date formatting.

See Also

New Features

Version 2.3

Version 2.2.1

Version 2.2

Version 1.1.2

Version 2.1.12

Version 2.1.11

Version 2.1.10

Version 2.1.9

Version 2.1.8

Version 2.1.7

Version 2.1.6

Version 2.1.5

Version 2.1.4

Version 2.1.3

Version 2.1.2

Version 2.1.1

Version 2.1

Version 2.0

Version 1.1.4

Version 1.1.3

Version 1.1.1

Version 1.1.0

Version 1.0.11

Version 1.0.10

Version 1.0.9

Version 1.0.12

Next

Version 1.0.11
Version 1.0.13

Did this topic help you? Email us your feedback.
Last updated: 7/27/2007 3:19:21 PM


Version 1.0.11

Bug Fixes

  • Fixed problems with concurrent runs on Oracle dbs.
  • Fixed writing large text fields on Oracle.
  • Fixed date formatting bug.

See Also

New Features

Version 2.3

Version 2.2.1

Version 2.2

Version 1.1.2

Version 2.1.12

Version 2.1.11

Version 2.1.10

Version 2.1.9

Version 2.1.8

Version 2.1.7

Version 2.1.6

Version 2.1.5

Version 2.1.4

Version 2.1.3

Version 2.1.2

Version 2.1.1

Version 2.1

Version 2.0

Version 1.1.4

Version 1.1.3

Version 1.1.1

Version 1.1.0

Version 1.0.13

Version 1.0.10

Version 1.0.9

Version 1.0.12

Next

Version 1.0.10
Version 1.0.11

Did this topic help you? Email us your feedback.
Last updated: 7/27/2007 3:19:49 PM


Version 1.0.10

Enhancements

  • Added support for full date formatting (necessary for PARE/ArchiveManager on Oracle).

See Also

New Features

Version 2.3

Version 2.2.1

Version 2.2

Version 1.1.2

Version 2.1.12

Version 2.1.11

Version 2.1.10

Version 2.1.9

Version 2.1.8

Version 2.1.7

Version 2.1.6

Version 2.1.5

Version 2.1.4

Version 2.1.3

Version 2.1.2

Version 2.1.1

Version 2.1

Version 2.0

Version 1.1.4

Version 1.1.3

Version 1.1.1

Version 1.1.0

Version 1.0.13

Version 1.0.11

Version 1.0.9

Version 1.0.12

Next

Version 1.0.9
Version 1.0.10

Did this topic help you? Email us your feedback.
Last updated: 8/1/2007 9:25:37 AM


Version 1.0.9

Enhancements

  • Added support for Clarify 9.0.
  • Improved Oracle searching on searchable fields.

Bug Fixes

  • Fixed problem with group sets on Oracle.

See Also

New Features

Version 2.3

Version 2.2.1

Version 2.2

Version 1.1.2

Version 2.1.12

Version 2.1.11

Version 2.1.10

Version 2.1.9

Version 2.1.8

Version 2.1.7

Version 2.1.6

Version 2.1.5

Version 2.1.4

Version 2.1.3

Version 2.1.2

Version 2.1.1

Version 2.1

Version 2.0

Version 1.1.4

Version 1.1.3

Version 1.1.1

Version 1.1.0

Version 1.0.13

Version 1.0.11

Version 1.0.10

Version 1.0.12

Next

Version 1.0.12
Version 1.0.9

Did this topic help you? Email us your feedback.
Last updated: 7/27/2007 3:20:13 PM


Version 1.0.12

Enhancements

  • Made –license accept any spelling of license.

Bug Fixes

  • Fixed bug with delete object, which prevented objects from being deleted.

See Also

New Features

Version 2.3

Version 2.2.1

Version 2.2

Version 1.1.2

Version 2.1.12

Version 2.1.11

Version 2.1.10

Version 2.1.9

Version 2.1.8

Version 2.1.7

Version 2.1.6

Version 2.1.5

Version 2.1.4

Version 2.1.3

Version 2.1.2

Version 2.1.1

Version 2.1

Version 2.0

Version 1.1.4

Version 1.1.3

Version 1.1.1

Version 1.1.0

Version 1.0.13

Version 1.0.11

Version 1.0.10

Version 1.0.9

Next

Quick Start Guide
Version 1.0.12

Did this topic help you? Email us your feedback.
Last updated: 7/27/2007 3:19:37 PM


Quick Start Guide

This section will help you to get started with ArchiveManager.

In This Chapter

Files Shipped with ArchiveManager

Installing ArchiveManager

Limitations

Localizing ArchiveManager

Running ArchiveManager

Quick Facts about ArchiveManager

Next

Files Shipped with ArchiveManager
Quick Start Guide

Did this topic help you? Email us your feedback.
Last updated: 8/1/2007 9:25:42 AM


Files Shipped with ArchiveManager

ArchiveManager is shipped as a zip file containing the user guide, the executable file, the object files, sample purge/archive directives files, and a string list file.

  • The object files are included in case your sharable library has been altered, in which case, you must relink ArchiveManager to your local library. Go to the Relinking ArchiveManager section for more information.
  • The sample purge/archive directives files are included to show how ArchiveManager generated directives files should look after editing. Go to the Generating Purge/Archive Directives Files section for more information.
  • The string list file contains a list of ArchiveManager strings and related fc_strings table id numbers. The strings can be altered in the fc_string table for internationalization purposes.

See Also

Quick Start Guide

Installing ArchiveManager

Limitations

Localizing ArchiveManager

Running ArchiveManager

Quick Facts about ArchiveManager

Next

Installing ArchiveManager
Files Shipped with ArchiveManager

Did this topic help you? Email us your feedback.
Last updated: 8/1/2007 9:25:45 AM


Installing ArchiveManager

Copy the executable program supplied in the ArchiveManager zip file to a PATH directory. We recommend that you place the executable program in a new directory and add that directory to the PATH environment variable.

See Also

Quick Start Guide

Files Shipped with ArchiveManager

Limitations

Localizing ArchiveManager

Running ArchiveManager

Quick Facts about ArchiveManager

Next

Limitations
Installing ArchiveManager

Did this topic help you? Email us your feedback.
Last updated: 8/1/2007 9:25:47 AM


Limitations

At this time, ArchiveManager does not support Traveler enabled databases or databases that use the extended range of objids.

See Also

Quick Start Guide

Files Shipped with ArchiveManager

Installing ArchiveManager

Localizing ArchiveManager

Running ArchiveManager

Quick Facts about ArchiveManager

Next

Localizing ArchiveManager
Limitations

Did this topic help you? Email us your feedback.
Last updated: 8/1/2007 9:25:49 AM


Localizing ArchiveManager

The strings returned by ArchiveManager for notices and errors are localizable - they can be returned in a different language. These localized strings are not provided as part of the base product; however, ArchiveManager will honor these localized strings if they exist in your database. For more information about how to set up localized strings, contact Dovetail Software.

Note: ArchiveManager assumes that all input data is in the iso8859-1 code page.

See Also

Quick Start Guide

Files Shipped with ArchiveManager

Installing ArchiveManager

Limitations

Running ArchiveManager

Quick Facts about ArchiveManager

Next

Running ArchiveManager
Localizing ArchiveManager

Did this topic help you? Email us your feedback.
Last updated: 12/13/2007 4:57:10 PM


Running ArchiveManager

ArchiveManager imports, exports, purges, and archives data from Clarify databases, and it generates prototype purge/archive directives files. ArchiveManager is run from a command line.

See Also

Quick Start Guide

Files Shipped with ArchiveManager

Installing ArchiveManager

Limitations

Localizing ArchiveManager

Quick Facts about ArchiveManager

Next

Entering User and Database Information
Running ArchiveManager

Did this topic help you? Email us your feedback.
Last updated: 8/1/2007 9:25:54 AM


Entering User and Database Information

The user and database information must be entered either on each ArchiveManager command line or stored in the clarify.env file local to ArchiveManager.

  • To run ArchiveManager with the user and database information stored in the clarify.env file, for example:
    diet –import data.dat
  • To run ArchiveManager without this information stored in the clarify.env file, for example:
    diet -user_name <username> -password <password> -db_name <database name> -db_server <database server> –import data.dat

The user and database information can be stored in the clarify.env file as the following lines:

user_name=<username>

password=<password>

db_name=<database name>

db_server=<database server>

Note: The command syntax examples in this guide assume that the user and database information is stored in the clarify.env file.

See Also

Running ArchiveManager

Installing the ArchiveManager License Key

Import

Export

Purge/Archive

Generate

Next

Installing the ArchiveManager License Key
Entering User and Database Information

Did this topic help you? Email us your feedback.
Last updated: 8/1/2007 9:29:12 AM


Installing the ArchiveManager License Key

The license key must be installed the first time ArchiveManager is run. After that, it is stored in the database. Upon the initial creation of a database, place the key in the file 'c:\TEMP\diet_license' for NT systems, or '/tmp/diet_license' for UNIX systems.

To install the ArchiveManager license key:

Open a command line and enter the following command:

diet –license <license key>

See Also

Running ArchiveManager

Entering User and Database Information

Import

Export

Purge/Archive

Generate

Next

Import
Installing the ArchiveManager License Key

Did this topic help you? Email us your feedback.
Last updated: 8/1/2007 9:26:03 AM


Import

To import objects to a database, use an import file and the command syntax to direct the import operation.

See Also

Running ArchiveManager

Entering User and Database Information

Installing the ArchiveManager License Key

Export

Purge/Archive

Generate

Next

Export
Import

Did this topic help you? Email us your feedback.
Last updated: 7/31/2007 3:52:13 PM


Export

To export objects from a database, use an export directives file and the command syntax to direct the export operation.

See Also

Running ArchiveManager

Entering User and Database Information

Installing the ArchiveManager License Key

Import

Purge/Archive

Generate

Next

Purge/Archive
Export

Did this topic help you? Email us your feedback.
Last updated: 7/31/2007 3:51:07 PM


Purge/Archive

To purge or archive items from a database, use a purge/archive directives file and the command syntax to direct the purge/archive operation. The only difference between purging and archiving is that purging removes data from the database and archiving does not.

See Also

Running ArchiveManager

Entering User and Database Information

Installing the ArchiveManager License Key

Import

Export

Generate

Next

Generate
Purge/Archive

Did this topic help you? Email us your feedback.
Last updated: 7/31/2007 4:50:49 PM


Generate

If satisfied with the Clarify supplied directives files, it is not necessary to generate new directives files. However, it is possible to generate prototype purge/archive directives files with the generate command syntax.

See Also

Running ArchiveManager

Entering User and Database Information

Installing the ArchiveManager License Key

Import

Export

Purge/Archive

Next

Quick Facts about ArchiveManager
Generate

Did this topic help you? Email us your feedback.
Last updated: 7/31/2007 3:49:44 PM


Quick Facts about ArchiveManager

  • It inputs with a free-form ASCII file – all extra spaces, tabs, and new lines are ignored. The ArchiveManager parser handles any variance.
  • It has its own syntax for each file type; however, it is also a complete superset of Dataex syntax, so that Dataex files continue to work.
  • It supports two forms of comments in the data fields:
    • C style comments: All text between /* and */ is a comment.
    • C++ style comments: All text following a // to the end of line is a comment.

      Note: If either of the comment formats are included in a string (text within two double quotes), then the symbols are treated as part of the string.

See Also

Quick Start Guide

Files Shipped with ArchiveManager

Installing ArchiveManager

Limitations

Localizing ArchiveManager

Running ArchiveManager

Next

Command Syntax
Quick Facts about ArchiveManager

Did this topic help you? Email us your feedback.
Last updated: 11/6/2007 12:10:54 PM


Command Syntax

ArchiveManager operations are executed with a command line. The command syntax is comprised of the command (diet) and the command parameters. To run ArchiveManager, one of the following five required parameters must be declared: import, export, purge, archive, or generate. This section describes the five required parameters and other parameters that alter how ArchiveManager operates.

The sample command syntax in this section assumes the following:

  • The user and database information is stored in the clarify.env file. See the Entering User and Database Information section for more information.
  • A UNIX version of ArchiveManager is being used, which means command lines start with 'diet'. If using the Microsoft version of ArchiveManager, start command lines with 'diet.exe'.

In This Chapter

General Command Syntax

Import Command Syntax

Export Command Syntax

Purge/Archive Command Syntax

Generate Command Syntax

Next

General Command Syntax
Command Syntax

Did this topic help you? Email us your feedback.
Last updated: 8/1/2007 9:26:06 AM


General Command Syntax

These general command parameters can be used with the import, export, purge, archive, and generate parameters.

Parameter Name | Description | Value | Default | Unique to ArchiveManager
–user_name <user name> | Clarify database username. This required parameter must be entered on the command line or stored in the clarify.env file. For more information, see the Entering User and Database Information section. | String |  | No
–password <password> | Clarify database password. This required parameter must be entered on the command line or stored in the clarify.env file. For more information, see the Entering User and Database Information section. | String |  | No
–db_name <database name> | For SQL Server and Sybase databases, this is the name of the Clarify database. For Oracle databases, this is the net service name as defined in the tnsnames.ora file. This required parameter must be entered on the command line or stored in the clarify.env file. For more information, see the Entering User and Database Information section. | String |  | No
–db_server <database server> | Name of the machine that the database resides on. This parameter is required for SQL Server and Sybase, but ignored on Oracle databases. If required, the server name must be entered on the command line or stored in the clarify.env file. For more information, see the Entering User and Database Information section. | String |  | No
–date_format <date format> | Supplies a date format to ArchiveManager. | String | %m/%d/%Y %H:%M:%S | Yes
–date_quiet | Turns off warnings that result from date conversion issues. | Boolean | No | Yes
–errors_max | Sets the maximum number of errors allowed before terminating the program. If it is set to zero, no termination will occur. | Integer | 100 | Yes
–help | Lists the command line parameters. When run, the program is not executed. | Boolean | No | Yes
–license <license key> | ArchiveManager license key. This key is stored in the database and only needs to be supplied the first time ArchiveManager is run. Upon the initial creation of a database, place the key in the file 'c:\TEMP\diet_license' for NT systems, or '/tmp/diet_license' for UNIX systems. | String | Read from DB | Yes
–log_file <filename> | Names a file to write general output notices to, instead of writing them as standard errors on screen. If the filename is 'mes_file', the message file is used for the log_file. If no filename is specified after –log_file, a date stamped file will be created. | String | Standard errors | Yes
–mes_file <filename> | Names a file to write errors and warnings to, instead of writing them as standard errors on screen. If the file name is 'log_file', the log file is used for the message file. If no filename is specified after –mes_file, a date stamped file will be created. | String | Standard errors | Yes
–notices_off | Progress notices will not be reported. | Boolean | No | Yes
–sqllog <filename> | Prints the SQL commands generated by ArchiveManager into a file of your designation. | String | No log | No
–syntax_off | Minor syntax errors will not be reported. | Boolean | No | Yes
–timer | Turns on the internal code timers that report the timing of various ArchiveManager operations. When database timing is slow, this parameter can be used to help tune ArchiveManager runs. | Boolean | No | Yes
–warnings_off | Warning messages will not be reported. | Boolean | No | Yes

See Also

Command Syntax

Import Command Syntax

Export Command Syntax

Purge/Archive Command Syntax

Generate Command Syntax

Next

Import Command Syntax
General Command Syntax

Did this topic help you? Email us your feedback.
Last updated: 11/18/2008 10:03:20 AM


Import Command Syntax

Use the import command parameters to select the import file and to direct the import operation. Before a large import, we recommend backing up your database.

See Also

Command Syntax

General Command Syntax

Export Command Syntax

Purge/Archive Command Syntax

Generate Command Syntax

Next

Import Command Parameters
Import Command Syntax

Did this topic help you? Email us your feedback.
Last updated: 7/31/2007 4:00:58 PM


Import Command Parameters

Parameter Name

Description

Value

Default

Unique to ArchiveManager

–import <filename>

Enter the –import switch, followed by the file, or files, containing the object data to import. Files are processed in the order they are listed. This parameter is required to import.

String

No

–allow_null

Allows a null relation to be a part of an object's unique key.

Boolean

No

Yes

–bad_fields

When a mismatch occurs and the archive contents contain fields or relations that are not present on the target database of an import, ArchiveManager issues an error and terminates the data load. To prevent ArchiveManager from terminating the import, use the –bad_fields parameter to tell ArchiveManager to issue warnings instead of errors.

Boolean

No

Yes

–bad_schema

Allows ArchiveManager to import data that has a schema revision value that disagrees with the schema revision of the database.

Boolean

No

Yes

–eindex

Generates new DART indexes for the import file and does not import the data into the database.

Boolean

No

Yes

–esplit <split string>

Uses the specified string as the split string in DART index files.

String

!!#*$

Yes

–insert_only

Use -insert_only when only using the import command to insert new rows into a database without updating or deleting data. This parameter notifies ArchiveManager that all objects in the input stream are new, so that it will not look for updates on existing objects, which will reduce the import time. This parameter is not to be confused with the insert_only keyword added to Dataex in Clarify 12.0. For more time-saving tactics, see the –no_recovery entry.

Boolean

No

Yes

–lite

Because ArchiveManager stores much of its information in memory, large imports require considerable memory swapping, which can slow down the import if using a machine with less than 1 gig of memory. To limit the memory swapping, use the –lite parameter, which limits the amount of information saved in memory for each object.

Recommendation: Only use this parameter if there is not enough system memory and swap file space to run ArchiveManager efficiently.

Boolean

No

Yes

–mto

Allows OTOP (one to one primary) relations that have been treated as MTO (many to one) by Clarify to also be treated as MTO relations in ArchiveManager. Use this parameter to allow exported data with this error to be reimported.

String

Yes

–no_recovery

When importing a large amount of data, the recovery files will also be large and could potentially take a long time to write out. To save time, you can use the –no_recovery parameter to prevent ArchiveManager from creating recovery files. If using this parameter, we recommend backing up your database as a safety measure. If the import fails, you can restore to the saved database and reload the data from scratch. For more time-saving tactics, see the –insert_only entry.

Boolean

No

Yes

–no_write

Only the verification parameters are run. No database data is inserted, updated, or deleted.

Boolean

No

Yes

–object <name>

The –purge parameter can generate archive files that contain thousands of object groups. To selectively reimport one or more of these groups and the related objects, use the –object parameter. The <name> value is the top-level object in the group. This parameter can be specified more than once.

String

All objects imported

Yes

–objid

An object's id is normally ignored during an import. With this parameter, object ids will be stored and used for unique keys.

Boolean

No

Yes

–pick_one

When testing references, if more than one object matching the unique list exists in the database, this parameter will select any one of them to match. These are normally reported as errors.

Boolean

No

Yes

–recovery

If an import error occurs and the import fails, ArchiveManager can recover and restart the import from where it left off. To recover, add –recovery to the original parameters and rerun ArchiveManager.

Boolean

No

Yes

–rfile

<filename>

When an import fails and the –recovery parameter is used to restart the process, by default, the recovery files are named recovery.1 and recovery.2. To define a different prefix filename, use the –rfile parameter with the -recovery parameter.

String

recovery

Yes

–uniqueness

A common import mistake is to have more than one archive entry in the import file refer to a single database object. When this occurs, the second archive entry overwrites the first. To check for overlap, use the –uniqueness parameter. If any problems are found, ArchiveManager will stop the data load.

Note: Uniqueness constraints are not checked by default, because this process can be time-consuming.

Boolean

No

Yes

–unused

Pulls table objids from the unused objid table. In later versions of Clarify, objids can be fetched, and if unused, returned to the system via the unused objid table. This parameter allows systems that are tight on objids to fetch objids first using this table.

Recommendation: Due to possible efficiency and locking problems, we recommend not using the unused objid table.

Boolean

No

Yes

See Also

Import Command Syntax

Import Command Syntax Examples

Next

Import Command Syntax Examples
Import Command Parameters

Did this topic help you? Email us your feedback.
Last updated: 12/13/2007 4:57:35 PM


Import Command Syntax Examples

  • Example 1:
    diet -import data.dat

    The system will insert the data.dat file contents into the database.
  • Example 2:
    diet –objid –import data.dat

    The system will store and use objids as unique keys and insert the data.dat file contents into the database.
  • Example 3:
    diet –import new.dat –insert_only –no_recovery

    This command line will help to speed up the import of a pristine database. The –insert_only parameter tells the system to only insert new rows into the database without updating or deleting data, and the –no_recovery parameter tells the system to not create recovery files.

    Another way to speed up initial imports is to remove the database indexes and reinstate them after the run. However, this will slow down ArchiveManager purge runs and the database for general use.

See Also

Import Command Syntax

Import Command Parameters

Next

Export Command Syntax
Import Command Syntax Examples

Did this topic help you? Email us your feedback.
Last updated: 11/6/2007 12:20:03 PM


Export Command Syntax

Use the export command parameters to select the export directives file and to control how data is exported from the database. No instances are deleted from the database when using the export command.

See Also

Command Syntax

General Command Syntax

Import Command Syntax

Purge/Archive Command Syntax

Generate Command Syntax

Next

Export Command Parameters
Export Command Syntax

Did this topic help you? Email us your feedback.
Last updated: 7/31/2007 4:04:59 PM


Export Command Parameters

Parameter Name | Description | Value | Default | Unique to ArchiveManager
–export <filename> | Enter the –export switch, followed by the file to which the exported objects will be written. This parameter is required to export. | String |  | No
–directive <filename> | Enter the –directive switch, followed by the file containing the directives for which objects to export. This parameter is required to export. The export directives files cannot be created by using the –generate command; it must be created by hand. See the Export Directives File section for more information. | String |  | No
–auto_unique | By default, ArchiveManager does not export unique keys. If this is required, for example, if the ArchiveManager export will be sent to a system that only uses Dataex, use the –auto_unique parameter to include the unique keys with the export. | Boolean | No | Yes
–compact | Writes out a smaller output file. This file can be a quarter of the size of a normal output file, but it is not easily readable. | Boolean | No | Yes
–no_expdef | By default, ArchiveManager exports all fields, even if the fields do not contain data. To only export fields with data, use the –no_expdef parameter. | Boolean | No |
–objid | Outputs the object ids into the export file, and allows the objid to be used as a unique key. Warning: We do not recommend using this parameter, but Clarify supplied .arc files rely on it. | Boolean | No | Yes

See Also

Export Command Syntax

Export Command Example

Next

Export Command Example
Export Command Parameters

Did this topic help you? Email us your feedback.
Last updated: 11/6/2007 12:21:20 PM


Export Command Example

  • diet -export exported_cases.dat –directive export_cases.arc

    The export_cases.arc file defines which cases and related objects will be exported into the exported_cases.dat file.

See Also

Export Command Syntax

Export Command Parameters

Next

Purge/Archive Command Syntax
Export Command Example

Did this topic help you? Email us your feedback.
Last updated: 7/30/2007 1:29:04 PM


Purge/Archive Command Syntax

Use the purge/archive command parameters to select the purge/archive directives file and to control how data is purged or archived from the database.

See Also

Command Syntax

General Command Syntax

Import Command Syntax

Export Command Syntax

Generate Command Syntax

Next

Purge/Archive Command Parameters
Purge/Archive Command Syntax

Did this topic help you? Email us your feedback.
Last updated: 7/31/2007 4:05:15 PM


Purge/Archive Command Parameters

Parameter Name

Description

Value

Default

Unique to ArchiveManager

–purge

To purge, enter the –purge switch. When purging, objects are written to an archive file and deleted from the database. The objects to be purged are defined by a purge/archive directives file. This parameter is required for to purge.

Boolean

Yes

–archive

To archive, enter the –archive switch. When archiving, objects are written to an archive file but not deleted from the database. The objects to be archived are defined by a purge/archive directives file. This parameter is required to archive.

Boolean

No

–directive <filename>

Enter the –directive switch, followed by the purge/archive directives file that defines which objects to purge or archive. This parameter is required to purge or archive. See the Purge/Archive Directives File section for more information. A prototype of the purge/archive directives file can be created by using the –generate switch.

String

No

–adp_verbose

Allows verbose/extended information to be placed in the adp_db_comments table.

Boolean

No

Yes

–auto_unique

Outputs a unique key for each object.

Note: The objid field is the unique field if –objid is specified.

Boolean

No

Yes

–checksum <license key>

Generates an updated file checksum - no purge or archive will occur. To use this parameter, you must have write permission to the file. This permission requirement prevents any unauthorized creation of purge/archive directives files. For more information, refer to the Updating the Checksum section.

Hexa-decimal

Yes

–compact

Writes out a smaller output file. This file can be a quarter of the size of a normal output file, but it is not easily readable.

Boolean

No

Yes

–eindex

Generates a DART index file for the archive. Before ArchiveManager version 2.0.1, the DART index file was generated by default.

Boolean

No

Yes

–esplit <split string>

Uses the specified string as the split string in DART index files.

String

!!#*$

Yes

–index_analyze

Analyzes the purge file and reports what indexes should be created. When this parameter is used, the purge will not be performed.

Boolean

No

Yes

–index_no_create

To aid purging, this parameter tells the system to not create indexes in the Clarify database.

Note: We recommend allowing ArchiveManager to create indexes; however, not all ArchiveManager users have permission to create indexes.

Boolean

No

Yes

–index_save

Saves the indexes created during a purge, which are normally deleted by default.

Boolean

No

Yes

–index_threshold <integer>

Creates an index if there are 'n' objects that can be accessed through this relation.

Integer

1

Yes

–expdef

Export fields that have no value in the database.

By default, ArchiveManager will only write data to the export file is the field contains data. Empty strings and NULL values will not be exported. To export all fields, including empty strings and NULLs, use the –expdef parameter.

Boolean

No

Yes

–no_iterative_purge

Objects will be deleted at the end of the purge run only, instead of during the purge as object hierarchies are read and written from the database.

Boolean

No

Yes

–no_stopif

The stop_if statements in the purge/archive directives file will not be processed. This parameter is useful when archiving out items that will be imported into a parallel database.

Boolean

No

Yes

–no_write

No archive file will be generated.

Boolean

No

Yes

–objid

Outputs the object ids into the archive file, and allows the objid to be used as a unique key.

Warning: We do not recommend using this parameter, but Clarify supplied .arc files rely on it.

Boolean

No

Yes

–P_template <filename>

The location of the template file is used as the basis of the DART index file. The default is to use the standard format compiled internally into ArchiveManager.

String

Built in template is used

Yes

–recycle <object type>

In a purge, use the –recycle parameter to return the objids of a specified object type to the unused table. This parameter can be given multiple times to specify different object types, or, to recycle all objids, use 'all'. This parameter is supplied for users whose system is short on objids and for those who need to recover the objids by purging objects. This parameter only works for Clarify versions that support the unused table.

Warning: Recycling objids of existing but purged objects breaks the CLARIFY data model.

Warning: Recycling objids and purging by using objids as unique fields is allowed, but this may cause your database to be corrupted when the archive is reimported to the database.

String

Yes

–report <number>

Reports on the progress every <number> objects purged/archived out. The default is chosen as a number between 1% and 0.5% of the total objects.

Integer

Approx

1% of total

Yes

–thorough

Objects being deleted will be thoroughly purged: OTMs will be reset, OTOFs pointing to the object will be reset, related MTMs will be deleted, and related binary data records will be deleted.

Boolean

No

Yes

–where <SQL expression>

Used for purging, this parameter will overwrite the WHERE condition in the archive file and only select the objects that meet the conditions of the specified SQL expression.

Note: The string in the where clause is an exact SQL search clause, may need to be enclosed in double quotes, see the examples in the next section.

It must match a search clause that would work in SQL. Therefore, all data must be in the format of the SQL search, including dates. The ORACLE date format is: 'MM/DD/YYYY HH24:MI:SS'

When dealing with Unicode string constants, you must precede all Unicode strings with a capital letter N. For example, "WHERE title = N'résumé'"

String

Use archive file where clause

Yes

See Also

Purge/Archive Command Syntax

Purge/Archive Command Syntax Examples

Next

Purge/Archive Command Syntax Examples
Purge/Archive Command Parameters

Did this topic help you? Email us your feedback.
Last updated: 1/5/2011 5:15:34 PM


Purge/Archive Command Syntax Examples

  • Example 1:
    diet -archive -directive gen_case.arc -checksum 123456AA

    A new checksum will be generated for the gen_case.arc file. The archive will not run.
  • Example 2:
    diet –archive –directive case.arc –export casedata.dat

    The case.arc directives file defines which cases and related objects will be archived and exported into the casedata.dat file. The affected files will remain in the database.
  • Example 3:
    diet -purge -directive case.arc –export casedata.dat

    The case.arc directives file defines which cases and related objects will be purged (deleted) and exported into the casedata.dat file.
  • Example 4:
    diet -purge -directive case.arc –export casedata.dat –where 'objid > 0' –auto_unique

    Every case and related object defined by the case.arc directives file that has a positive objid will be purged (deleted) and exported into the casedata.dat file. Each object placed in the casedata.dat file will have a unique key.
  • Example 5:
    diet -purge -directive case.arc –export casedata.dat –where "title like '%failure%'"

    Every case and related object defined by the case.arc directives file with title containing the word 'failure' will be purged (deleted) and exported into the casedata.dat file.
  • Example 6:
    diet –purge -directive case.arc -no_write

    The case.arc directives file defines which cases and related objects will be purged from the database. No archive file will be generated, because the –no_write parameter is used.

See Also

Purge/Archive Command Syntax

Purge/Archive Command Parameters

Next

Generate Command Syntax
Purge/Archive Command Syntax Examples

Did this topic help you? Email us your feedback.
Last updated: 12/5/2008 10:04:43 AM


Generate Command Syntax

In most cases, using the Clarify supplied directives files for purging and archiving will suffice; however, ArchiveManager can generate prototype purge/archive directives files if required. Export directives files cannot be created with the -generate command. See the Generating a Purge/Archive Directives File sections for more information.

See Also

Command Syntax

General Command Syntax

Import Command Syntax

Export Command Syntax

Purge/Archive Command Syntax

Next

Generate Command Parameters
Generate Command Syntax

Did this topic help you? Email us your feedback.
Last updated: 8/1/2007 9:26:36 AM


Generate Command Parameters

Parameter Name | Description | Value | Default | Unique to ArchiveManager
–generate | To generate a prototype purge/archive directives file, enter the –generate switch. This parameter is required to generate. See the Generating Purge/Archive Directives File section for more information. | String |  | Yes
–export | Enter the name of the file to generate directives into. This parameter is required to generate. | String |  | Yes
–auto_unique | Outputs a unique key for each object. Recommended: Using this parameter is highly recommended. | Boolean | No | Yes
–comments | Adds comments to the generated file. | Boolean | No | Yes
–delete_only | Creates a directives file that will only be used for database deletions. No references will get checked, and any archive file generated will not be reimportable. This type of directives file makes for fast deletions. |  |  |
–no_gen | Points to a file that contains a list of objects and relations for which purge information is not generated. | String |  | Yes
–objid | Object ids are used as the unique fields of objects. | Boolean | No | Yes

See Also

Generate Command Syntax

Generate Command Syntax Example

Next

Generate Command Syntax Example
Generate Command Parameters

Did this topic help you? Email us your feedback.
Last updated: 11/6/2007 12:23:41 PM


Generate Command Syntax Example

  • diet –generate case -auto_unique –export case.arc

    The first pass of the case.arc purge/archive directives file will be generated with unique keys for each object. See the Generating a Purge/Archive Directives File sections for more information.

See Also

Generate Command Syntax

Generate Command Parameters

Next

Import Files
Generate Command Syntax Example

Did this topic help you? Email us your feedback.
Last updated: 7/31/2007 4:52:36 PM


Import Files

Import files define which objects will be inserted, updated, and/or deleted from the database. Each object to be inserted, updated, or deleted is completely written to the database in a single transaction, so that the database won't be corrupted by object fragments if the operation fails. The standard import file extension is .dat. Before a large import, we recommend backing up your database.

In This Chapter

Example Import File

Import Objects

Common Import Object Definition Elements

Complete List of Import Object Definition Elements

Additional Import File Notes

Next

Example Import File
Import Files

Did this topic help you? Email us your feedback.
Last updated: 7/31/2007 4:04:27 PM


Example Import File

This example import file shows how the import objects and object definition elements fit together. It imports three addresses and one site into the database, and it deletes one address. In doing so, it references four existing objects: country, state_prov, time_zone, and bus_org.

REFERENCE TYPE="country", NAME="USA", UNIQUE_FIELD=name
 FIELDS
  name="USA";
 END_FIELDS
END_REFERENCE NAME="USA"

REFERENCE TYPE="state_prov", NAME="Texas", UNIQUE_FIELD=name

 FIELDS

  name="TX";

 END_FIELDS

END_REFERENCE NAME="Texas"

REFERENCE TYPE="time_zone", NAME="CST", UNIQUE_FIELD=name

 FIELDS

  name="CST";

 END_FIELDS

END_REFERENCE NAME="CST"

REFERENCE TYPE="bus_org", NAME="BO", UNIQUE_FIELD=objid

 FIELDS

  objid=-2;

 END_FIELDS

END_REFERENCE NAME="BO"

DELETE TYPE="address", NAME="Ship_1", UNIQUE_FIELD=address, address_2, zipcode

 FIELDS

  address="1255 Redbud Creek";

  address_2="Apt 123";

  city="Austin";

  state="TX";

  zipcode="78759";

 END_FIELDS

 RELATIONS

  TO_NAME="USA" REL="address2country";

  TO_NAME="Texas" REL="address2state_prov";

  TO_NAME="CST" REL="address2time_zone";

 END_RELATIONS

END_OBJECT NAME="Ship_1"

OBJECT TYPE="address", NAME="Prim_1", UNIQUE_FIELD=address, address_2, zipcode

 FIELDS

  address="125 Main St";

  address_2="Apt 623";

  city="Austin";

  state="TX";

  zipcode="78759";

 END_FIELDS

 RELATIONS

  TO_NAME="USA" REL="address2country";

  TO_NAME="Texas" REL="address2state_prov";

  TO_NAME="CST" REL="address2time_zone";

 END_RELATIONS

END_OBJECT NAME="Prim_1"

OBJECT TYPE="address", NAME="Bill_1", UNIQUE_FIELD=address, address_2, zipcode

 FIELDS

  address="8900 Business Park Dr";

  address_2="Suite 555";

  city="Austin";

  state="TX";

  zipcode="78759";

 END_FIELDS

 RELATIONS

  TO_NAME="USA" REL="address2country";

  TO_NAME="Texas" REL="address2state_prov";

  TO_NAME="CST" REL="address2time_zone";

 END_RELATIONS

END_OBJECT NAME="Bill_1"

OBJECT TYPE="site", NAME="site_1", UNIQUE_FIELD=site_id

 FIELDS

  site_id="DT";

  name="Dovetail Software";

  type=1;

  site_type="CUST";

  status=0;

 END_FIELDS

 RELATIONS

  TO_NAME="Prim_1" REL="cust_primaddr2address";

  TO_NAME="Bill_1" REL="cust_billaddr2address";

  TO_NAME="BO" REL="primary2bus_org";

 END_RELATIONS

END_OBJECT NAME="site_1"

See Also
Import Files
Import Objects
Common Import Object Definition Elements
Complete List of Import Object Definition Elements
Additional Import File Notes

Next
Import Objects

 Example Import File

            Did this topic help you? Email us your feedback.

Last updated: 8/1/2007 9:09:51 AM


Import Objects

Import files can contain three import object types, which each have similar formats:

  • OBJECT – Inserts and updates data.
  • DELETE – Deletes data.
  • REFERENCE – References existing database objects.

See Also

Import Files

Example Import File

Common Import Object Definition Elements

Complete List of Import Object Definition Elements

Additional Import File Notes

Next

Object
Import Objects

Did this topic help you? Email us your feedback.
Last updated: 7/30/2007 2:24:46 PM


Object

OBJECT <header> [<uniques>] [<fields>] [<relations>] END_OBJECT

OR

OBJECT [INSERT_ONLY] <header> [<uniques>] [<fields>] [<relations>] END_OBJECT

The objects defined by the OBJECT element will be either updated or inserted into the database, which is determined by the unique key(s) defined in the <uniques> element. If the <uniques> match an existing database object, the object will be updated with the OBJECT information. If the <uniques> do not match an existing database object, the object will be classified as new and inserted into the database.

By adding INSERT_ONLY to the OBJECT element, the object will be inserted if it doesn't already exist in the database, but it will not be updated if it does. This is not the same as the –insert_only command parameter.

See Also

Import Objects

Delete

Reference

Next

Delete
Object

Did this topic help you? Email us your feedback.
Last updated: 12/13/2007 4:58:43 PM


Delete

DELETE <header> [<uniques>] [<fields>] [<relations>] END_DELETE

The objects defined by the DELETE element will be deleted, along with all references to the object in the database. Only one database object can match the DELETE object.

Recommendation: The DELETE objects should use unique key descriptions, other than OBJID, to specify a unique match.

Warning: If you do not know the Clarify data model for a given set of objects, deleting a row, or rows, can be risky. For example, if a condition object is deleted without also deleting that condition's case object, the Clarify client may fail when a user tries to open the case.

See Also

Import Objects

Object

Reference

Next

Reference
Delete

Did this topic help you? Email us your feedback.
Last updated: 7/30/2007 3:10:25 PM


Reference

REFERENCE <header> [<uniques>] [<fields>] [<relations>] END_REFERENCE

Objects defined in the OBJECT and DELETE elements often refer to other objects in their relations and fields. For those references to be successful, use the REFERENCE element to describe those objects that already exist in the database. Only one database object can match a REFERENCE object.

Recommendation: The REFERENCE objects should use unique key descriptions, other than OBJID, to specify a unique match. For example, to clearly define a gbst_elm database row, the gbst_elm title field and the gbst_lst that the gbst_elm belongs to must be specified. Use a REFERENCE rather than updating the gbst_lst object, because the REFERENCE simply looks up the database object to verify that the referenced object exists and that the gbst_elm can be related to it.

See Also

Import Objects

Object

Delete

Next

Common Import Object Definition Elements
Reference

Did this topic help you? Email us your feedback.
Last updated: 7/30/2007 3:10:34 PM


Common Import Object Definition Elements

The object definition elements described in this section are the most commonly used with the import objects OBJECT, DELETE, and REFERENCE. For a complete list, go to the Complete List of Import Object Definition Elements section.

See Also

Import Files

Example Import File

Import Objects

Complete List of Import Object Definition Elements

Additional Import File Notes

Next

Header
Common Import Object Definition Elements

Did this topic help you? Email us your feedback.
Last updated: 7/30/2007 2:29:56 PM


Header

TYPE = <object type> NAME = <object name>

The <header> definition is required for the REFERENCE, OBJECT, and DELETE objects.

The <object type> value is the object type defined in the data dictionary. For example, the <object type> value might be 'contact' or 'case'.

The <object name> value is the name that other objects in the input file can use to reference this object. The name can be any text string. It is a unique identifier for the object in the input file only. It is not the object's database unique identifier, and it is not saved to the database. For example, when inserting a case row, if you enter the NAME as 'Case1', subsequent notes_log rows can use that name to relate to the case.

See Also

Common Import Object Definition Elements

Uniques

Fields

Relations

Clear Relations

Next

Uniques
Header

Did this topic help you? Email us your feedback.
Last updated: 7/31/2007 5:01:41 PM


Uniques

[UNIQUE_FIELDS = <field>[, <field>]…]

[UNIQUE_RELATIONS = <relation>[, <relation>]…]

The <uniques> definition is optional. It lists the fields and/or relations that form the object's unique key.

The <field> value is a field on the object; it must be specified in the fields section of the import object. The <relation> value is a relation on the object; it must be specified in the relations section of the import object. Either one or both of the <uniques> values can be listed. Note: If both are listed, the UNIQUE_FIELDS must be listed first.

The <uniques> definition can affect the import in different ways:

  • If the <uniques> definition is used with an OBJECT, and the fields and/or relations do not match any other database objects, a new object will be inserted.
  • If the <uniques> definition is used with a REFERENCE or DELETE, and the fields and/or relations do not match any other database objects, the system will issue an error.
  • If no <uniques> definition is entered for an OBJECT, ArchiveManager will first search for <uniques> already defined for the object type in the database index. If no unique fields or relations can be found, the object will be inserted as a new item.

See Also

Common Import Object Definition Elements

Header

Fields

Relations

Clear Relations

Next

Fields
Uniques

Did this topic help you? Email us your feedback.
Last updated: 8/1/2007 9:26:38 AM


Fields

The <fields> definition lists the field names and values for the object.

FIELDS

<field> = <value>;

END_FIELDS

The <field> value is a field on the object. Any number of fields can be listed within the FIELDS/END_FIELDS pair, but not all of the object's fields must be listed.

The <value> is either the value to assign to the field for an insert or update, or the value currently assigned to the field if it's a unique key. The <value> form must match the underlying data type of the field, because values are stored in the database exactly as entered. For example, integer database fields require an integer format.

When used with the OBJECT element, the object's fields are either inserted or updated. If one or more of the object's fields are not defined for an insert, the unlisted field(s) will be assigned a default value. If one or more of the object's fields are not defined for an update, the existing value(s) will be unchanged.

When used with the REFERENCE or DELETE element, any extra fields listed that are not part of the <uniques> list will be ignored.

This section describes how to construct common values used in the <fields> definition.

See Also

Common Import Object Definition Elements

Header

Uniques

Relations

Clear Relations

Next

String Values
Fields

Did this topic help you? Email us your feedback.
Last updated: 7/31/2007 5:02:50 PM


String Values

To assign a string to a field, use this form:

<field> = "<string>";

For example:

name="Dovetail Software";

Use double quotes for string values. String values can contain carriage returns. To specify a special character such as a double quote or backslash within a string, the special character must be preceded by a backslash (\).

See Also

Fields

Default and Null Values

Date Values

Binary Values

Integer Fields as References

Integer Fields as Table IDs

Next

Default and Null Values
String Values

Did this topic help you? Email us your feedback.
Last updated: 7/30/2007 3:14:43 PM


Default and Null Values

To assign a default or null value to a field, use this form:

<field> = DEFAULT;

<field> = NULL;

See Also

Fields

String Values

Date Values

Binary Values

Integer Fields as References

Integer Fields as Table IDs

Next

Date Values
Default and Null Values

Did this topic help you? Email us your feedback.
Last updated: 7/30/2007 3:16:45 PM


Date Values

To assign a date value to a field, use this form:

<field> = DATE "<date value>";

The <date value> can be a string or the word NOW. For example:

creation_date = DATE "1/1/99 08:00:00";

creation_date = DATE NOW;

If the <date value> is set to NOW, the field will be set to the current date. To specify the earliest possible database date, enter ?/?/? ?:?:? in quotes for the <date value>. To specify the latest possible date, enter */*/* *:*:* in quotes for the <date value>. The default is the earliest possible date.

See Also

Fields

String Values

Default and Null Values

Binary Values

Integer Fields as References

Integer Fields as Table IDs

Next

Binary Values
Date Values

Did this topic help you? Email us your feedback.
Last updated: 7/30/2007 3:15:57 PM


Binary Values

To assign a binary value to a field, use this form:

<field> = BINARY <binary_value> [, <binary_value>] … ;

The <binary_value> value is a string that only contains a hexadecimal digit sequence that defines the binary value. To break up long binary values into multiple <binary_value> strings, enter multiple <binary_value> strings separated by commas (as shown above).

See Also

Fields

String Values

Default and Null Values

Date Values

Integer Fields as References

Integer Fields as Table IDs

Next

Integer Fields as References
Binary Values

Did this topic help you? Email us your feedback.
Last updated: 7/30/2007 3:18:46 PM


Integer Fields as References

To use an integer field to specify a reference to an object, which is only needed occasionally, use this form:

<field> = REFERENCE <object name>;

The referenced object must be a part of the import stream. The <object name> value is the object header name of the referenced object (see the Header section). During an insert or update, the objid of the referenced object will be stored in the specified field. This cannot be achieved with Dataex; however, ArchiveManager can assign objids of other import stream objects directly to integer fields.

For example, to create a new site_part object, the objid of the related site must be placed in both a relation and the dir_site_objid field of the site_part object. If the object name of the related site is Site_FC, the applicable <field> definition on the site_part object could be the following:

dir_site_objid = REFERENCE "Site_FC";

See Also

Fields

String Values

Default and Null Values

Date Values

Binary Values

Integer Fields as Table IDs

Next

Integer Fields as Table IDs
Integer Fields as References

Did this topic help you? Email us your feedback.
Last updated: 8/1/2007 9:28:14 AM


Integer Fields as Table IDs

To set an integer field to a table ID number, use this form:

<field> = TABLE <table name>;

For example, to save a case table ID to a source_type field, the <field> definition could be the following:

source_type = TABLE case;

The TABLE definition is often used for exclusive relations.

See Also

Fields

String Values

Default and Null Values

Date Values

Binary Values

Integer Fields as References

Next

Relations
Integer Fields as Table IDs

Did this topic help you? Email us your feedback.
Last updated: 7/30/2007 3:21:07 PM


Relations

The <relations> definition lists the relations defined for the object. A common, and recommended, <relations> form:

RELATIONS

TO_NAME = <object_name> REL <relation_name>;

END RELATIONS

When relating two objects, the relation can be specified on either object or on both objects in the import file, even though the relation might be stored on just one object in the physical database.

If one or more of an object's relations is not specified for an update, the relation value will not change. If one or more of an object's relations is not specified for an insert, the relation value will be set to NULL.

If using the <relations> definition with a REFERENCE or DELETE, only specify the relations used for the unique identification of the row.

This section describes the five ways that the <relations> definition can be specified:

  • by an object name in the import stream (the recommended method)
  • by an objid of an existing object in the database
  • by a reference to a global string entry (gse)
  • by a search string to find a specific object in the database
  • by specifying the relation as null

See Also

Common Import Object Definition Elements

Header

Uniques

Fields

Clear Relations

Next

Specify the Relation by Name
Relations

Did this topic help you? Email us your feedback.
Last updated: 7/30/2007 4:18:38 PM


Specify the Relation by Name

The recommended method for specifying the <relations> definition is by name:

TO_NAME = <object name> REL <relation name>;

The <object name> value is the object header name of the referenced object (see the Header section). The <relation name> value is the relation to be used. For example, to relate a case object to an already referenced contact named "contact_joe_jones", the <relation> definition could be the following:

TO_NAME = "contact_joe_jones" REL "case_reporter2contact";

See Also

Relations

Specify the Relation by Objid

Specify the Relation by Global String Element

Specify the Relation by Search String

Specify the Relation as Null

Next

Specify the Relation by Objid
Specify the Relation by Name

Did this topic help you? Email us your feedback.
Last updated: 7/31/2007 5:05:31 PM


Specify the Relation by Objid

TO = <objid> REL <relation name>;

Defining <relations> by an objid is not a recommended method, because the objid of the related object must be used, which can be problematic when moving from one database to another. The same object may have different objids in different databases.

The <objid> value is the object id of the object being referenced. The <relation name> value is the relation to be used. For example, to relate a case to a contact with the objid 268435457, the <relation> definition could be the following:

TO = 268435457 REL "case_reporter2contact";

See Also

Relations

Specify the Relation by Name

Specify the Relation by Global String Element

Specify the Relation by Search String

Specify the Relation as Null

Next

Specify the Relation by Global String Element
Specify the Relation by Objid

Did this topic help you? Email us your feedback.
Last updated: 7/31/2007 5:05:57 PM


Specify the Relation by Global String Element

TO_GSE = "<gbst_lst title>:<gbst_elm title>" REL = <relation name>;

Defining <relations> by a global string element (gse) is not a recommended method, because it is inefficient. ArchiveManager must do multiple lookups to find the object.

The <gbst_lst title> value is the name of the global string list. For example, Response Priority Code might be a global string list. The <gbst_elm title> value is a global string element in that list; it must already exist in the database to use it. For example, Low, Medium, and High might be global string elements in the Response Priority Code list. The <gbse_elm title> is optional in this <relations> definition. If left off, the relation will be made to the default element in the specified list. The <relation name> value is the relation to be used.

To relate a case to the High priority element, the <relation> definition could be the following:

To_GSE = "Response Priority Code:High" REL = "respprty2gbst_elm";

See Also

Relations

Specify the Relation by Name

Specify the Relation by Objid

Specify the Relation by Search String

Specify the Relation as Null

Next

Specify the Relation by Search String
Specify the Relation by Global String Element

Did this topic help you? Email us your feedback.
Last updated: 8/1/2007 9:26:43 AM


Specify the Relation by Search String

TO_FIND = <search string> REL = <relation_name>;

Defining <relations> by a search string is not a recommended method, because it is inefficient.

The <search string> value is an SQL query used to find the object. The <relation name> value is the relation to be used. This method works the same as the Dataex search syntax. The object must already exist in the database, and the search must resolve to only one object.

See Also

Relations

Specify the Relation by Name

Specify the Relation by Objid

Specify the Relation by Global String Element

Specify the Relation as Null

Next

Specify the Relation as Null
Specify the Relation by Search String

Did this topic help you? Email us your feedback.
Last updated: 8/1/2007 9:28:16 AM


Specify the Relation as Null

NULL <relation_name>;

Use this form to specify a <relations> value as NULL. The <relation name> value is the relation to make null. Making a relation null is useful if the relation is a part of an object's unique key.

See Also

Relations

Specify the Relation by Name

Specify the Relation by Objid

Specify the Relation by Global String Element

Specify the Relation by Search String

Next

Clear Relations
Specify the Relation as Null

Did this topic help you? Email us your feedback.
Last updated: 7/31/2007 5:06:28 PM


Clear Relations

When ArchiveManager updates a database object, the existing OTM (one to many), OTOF (one to one foreign), and MTM (many to many) relations are not changed. This is normally a desired behavior; however, it is possible to unrelate specified relations.

Warning: Use CLEAR_RELATION with caution; it may lead to orphan database objects that are difficult to remove.

This section describes the the three forms that can unrelate relations:

  • Form 1:
    CLEAR_RELATION     <relation name>;
  • Form 2:
    CLEAR_RELATION     <relation name> from <object name>;
  • Form 3:
    CLEAR_RELATION     <relation name> from <objid>;

See Also

Common Import Object Definition Elements

Header

Uniques

Fields

Relations

Next

Form 1
Clear Relations

Did this topic help you? Email us your feedback.
Last updated: 8/1/2007 9:26:46 AM


Form 1

CLEAR_RELATION <relation name>;

In the first form, the <relation name> value is the relation to be removed.

For example, it would be problematic to restore and reimport a case and its associated log objects after it has been archived. The case object would be updated, while the log objects would be reinserted as new objects: the logs would be duplicated in the database. To prevent this and to break the relation to any activity entries that exist for the case, the <relation> definition could be the following:

CLEAR_RELATION case_act2act_entry;

See Also

Clear Relations

Form 2

Form 3

Unrelate Relations Example

Next

Form 2
Form 1

Did this topic help you? Email us your feedback.
Last updated: 7/30/2007 4:42:49 PM


Form 2

CLEAR_RELATION <relation name> from <object name>;

In the second form, the <relation name> value is the relation to be removed. The <object name> value is the object being referenced. When used, the referenced object will be unrelated.

See Also

Clear Relations

Form 1

Form 3

Unrelate Relations Example

Next

Form 3
Form 2

Did this topic help you? Email us your feedback.
Last updated: 7/30/2007 4:43:10 PM


Form 3

CLEAR_RELATION <relation name> from <objid>;

In the third form, the <relation name> value is the relation to be removed. The <objid> value is the objid of the object being referenced. When used, the referenced object will be unrelated.

See Also

Clear Relations

Form 1

Form 2

Unrelate Relations Example

Next

Unrelate Relations Example
Form 3

Did this topic help you? Email us your feedback.
Last updated: 7/30/2007 4:44:00 PM


Unrelate Relations Example

The three CLEAR_RELATION forms are useful for selectively unrelating objects. In this example, queues and users are connected by the relation queue2user, which tells the system which users can access the queue. Sally and Sam* are unrelated from the queue product_support, and the users Bob and Barbara* are added to the queue with the following:

Object type="queue" name="product_support_queue"
     Unique_field="title"
Fields
     Title="product_support"
End_fields
Relations
     Clear_relation queue2user user_sally;
     Clear_relation queue2user user_sam;
     To_name="user_bob" rel="queue2user"
     To_name="user_barbara" rel="queue2user"
End_relations
End_object name="product_support_queue"

*Note: The objects user_sally, user_sam, user_bob, and user_barbara must be defined in object headers in the import file.

See Also

Clear Relations

Form 1

Form 2

Form 3

Next

Complete List of Import Object Definition Elements
Unrelate Relations Example

Did this topic help you? Email us your feedback.
Last updated: 12/13/2007 4:59:28 PM


Complete List of Import Object Definition Elements

This is a complete list of the import object definition elements that can be used with the import objects REFERENCE, OBJECT, and DELETE.

Import Object Definition Elements | Values
binary_value | := <binary_string> , <binary_value> := <binary_string>
field_list | := <field> , field_list := <field>
field_specifier | := <field> = <integer value> := <field> = <float value> := <field> = <string value> := <field> = DATE <date string> := <field> = DATE NOW := <field> = BINARY binary_value := <field> = REFERENCE <object_name>
field_specifiers | := field_specifier ; field_specifiers := NULL
fields | := FIELDS field_specifiers END_FIELDS := NULL
group_statement | := GROUP object_statements END_GROUP
header | := TYPE = <object_type> NAME = <object_name>
object_statement | := OBJECT header uniques fields relations END_OBJECT := REFERENCE header uniques fields relations END_REFERENCE := DELETE header uniques fields relations END_DELETE
object_statements | := object_statement object_statements := NULL
relation_list | := <relation> , relation_list := <relation>
relation_list | := relation_specifier ; relation_specifiers := relation_specifier
relation_specifier | := TO = <object id> REL = <relation_name> := TO_NAME = <object name> REL = <relation_name> := TO_GSE = <gbst_lst title:gbst_elm title> REL = <relation_name> := TO_FIND = <search string> REL = <relation_name> := NULL <relation_name> := CLEAR_RELATION := CLEAR_RELATION <relation_name> := CLEAR_RELATION <object id>
relations | := RELATIONS relation_specifiers END_RELATIONS
statement | := object_statement := group_statement
statements | := statement statements := NULL
unique_fields | := UNIQUE_FIELDS = field_list
unique_relations | := UNIQUE_RELATIONS = relation_list
uniques | := unique_field := unique_relations := unique_fields unique_relations := NULL

See Also

Import Files

Example Import File

Import Objects

Common Import Object Definition Elements

Additional Import File Notes

Next

Additional Import File Notes
Complete List of Import Object Definition Elements

Did this topic help you? Email us your feedback.
Last updated: 11/6/2007 12:26:02 PM


Additional Import File Notes

This section contains additional import file notes.

See Also

Import Files

Example Import File

Import Objects

Common Import Object Definition Elements

Complete List of Import Object Definition Elements

Next

Grouping Import Transactions
Additional Import File Notes

Did this topic help you? Email us your feedback.
Last updated: 7/30/2007 4:53:47 PM


Grouping Import Transactions

Each object to be inserted, updated, or deleted is completely written to the database in a single transaction, so that the database won't be corrupted by object fragments if the operation fails. This safety measure can be extended to groups of objects.

Use the GROUP element to include more than one object in a single transaction with the database, so that the transaction will fail if any single insert, update, or delete within the group fails. Place GROUP before the first object to be included and END_GROUP after the last object. GROUP/END_GROUP pairs cannot be nested within each other, but can be used as many times as needed.

For example, when a case is created, the case record, condition record, activity log record, and time_bomb record must all be inserted, and the num_scheme table must be updated. This transaction should occur as a group, because if one of these objects fails to be inserted, the Clarify database would be corrupted by the missing data.

See Also

Additional Import File Notes

Verifying the Database Revision

Next

Verifying the Database Revision
Grouping Import Transactions

Did this topic help you? Email us your feedback.
Last updated: 7/30/2007 4:54:27 PM


Verifying the Database Revision

To verify that the database revision is consistent, place the SCHEMA_REV setting above all OBJECT, REFERENCE, and DELETE objects.

SCHEMA_REV <revision>;

If the import file has a wrong schema revision and attempts to enter the database, the program will stop. To force the import, use the –bad_schema command parameter.

See Also

Additional Import File Notes

Grouping Import Transactions

Next

Directives Files
Verifying the Database Revision

Did this topic help you? Email us your feedback.
Last updated: 7/30/2007 4:55:47 PM


Directives Files

Directives files are required for archiving, purging, and exporting data. They define the actions to be taken during the export, purge, and archive operations. The standard directives file extensions are .arc and .dir.

In This Chapter

Purge/Archive Directives Files

Export Directives Files

Next

Purge/Archive Directives Files
Directives Files

Did this topic help you? Email us your feedback.
Last updated: 7/31/2007 11:30:58 AM


Purge/Archive Directives Files

Purge/archive directives files can be used interchangeably for both purge and archive operations, which function almost identically. These files define the objects and related objects to be purged or archived from the database. The only difference between purging and archiving is that purging removes data from the database and archiving does not.

ArchiveManager directive grammar is a superset of Dataex directive grammar – the ArchiveManager and Dataex directives files achieve similar results.

See Also

Directives Files

Export Directives Files

Next

Generating Purge/Archive Directives Files
Purge/Archive Directives Files

Did this topic help you? Email us your feedback.
Last updated: 8/1/2007 9:28:19 AM


Generating Purge/Archive Directives Files

In most cases, using the easily editable Clarify-supplied directives files for purging and archiving is sufficient. However, if new directives files are needed for new objects or for a significantly altered schema, the –generate command parameter can be used to iteratively create new directives files. These new files can be used for archiving and purging, but not for exporting, which requires a simple directives file structure.

An ArchiveManager generated purge/archive directives file has the same basic structure as a Clarify directives file, because during the generation process, it consults the table definitions and recursively follows the relations down. Because the generated purge/archive directives file uses ArchiveManager routines extensively, these files are not compatible with Dataex.

See Also

Purge/Archive Directives Files

Updating the Checksum

Common Purge/Archive Directives Elements

Complete List of Purge/Archive Directives Elements

Recursively Deleting Objects

Example Purge/Archive Directives File

Example Purge/Archive Directives File with Routines

Next

To Generate a Purge/Archive Directives File
Generating Purge/Archive Directives Files

Did this topic help you? Email us your feedback.
Last updated: 8/1/2007 9:28:21 AM


To Generate a Purge/Archive Directives File

  1. Run the –generate command parameter for a selected object type. For example:

    diet –generate case -auto_unique –export case.arc

    This will generate a very large case.arc prototype file that is the starting point for a usable purge/archive directives file.

    Note: The generated file does not have unique keys by default. While it is not required, it is highly recommended that the –auto_unique command parameter be used on the command line, as shown above. This parameter will generate, when possible, unique keys for the objects. If a unique key cannot be determined on a reference object, the objid will be used and a warning issued. Unique keys containing objid as a unique field will be ignored for this first generation, unless the –objid command parameter is used. Warnings will be issued for references that do not have unique keys. See the Common Objects that Need Unique Keys section for more information.

  2. Review the generated file. Take note of the relations that TO clauses should not be generated for, such as for objects that do not exist in your database. Place these in the no_gen file, so that they will not be generated in the next pass. See the no_gen File section for more information.
  3. Run the –generate command again, and include the no_gen file. For example:

    diet –generate case –auto_unique –no_gen case.no_gen –export case.arc
  4. Repeat steps 2 and 3, continuing to add more objects and relations to the no_gen file.
  5. During the last few passes, as the purge/archive directives file gets closer to the final version, add these instructions to the no_gen file:
    • Switch any objects that should be exported but are referenced, and vice versa, in the no_gen file.
    • For any reference which generates a unique key of objid, add its unique constraints to the no_gen file. Go to the Common Objects that Need Unique Keys section for a list.
  6. In the last pass, add any required stop_if statements to the no_gen file.
  7. Check the file carefully; the generated routines might have to be manually removed, edited, or added.
  8. Update the checksum in the final directive file. See the Updating the Checksum section for more information.
  9. Test the generated directive file with the –archive command parameter before using it for a –purge.

See Also

Generating Purge/Archive Directives Files

no_gen File

Sample Files Shipped with ArchiveManager

Next

no_gen File
To Generate a Purge/Archive Directives File

Did this topic help you? Email us your feedback.
Last updated: 12/13/2007 5:00:07 PM


no_gen File

Purge/archive directives file generation is an iterative process that requires a no_gen file. The no_gen file is a set of instructions for the –generate command to follow. It specifies objects and reference relations to not generate TO clauses for during the –generate process, and it can also specify other actions for the generate process.

For example:

case:case_victim2case

site

case:case2part_used:reference

This section of the no_gen file gives the –generate command these instructions:

  • Do not generate a TO clause for the case object through the case_victim2case relation.
  • Do not generate a TO clause for the site object.
  • Traverse case2part_used as a reference.

Here's another example:

case:stop_if:table_case t2::table_case t1::(t2.case_victim2case=t1.objid)

gbst_elm:Unique_Field:title

gbst_elm:Unique_Relation:gbst_elm2gbst_lst

address:no_delete

participant:exclusive:focus_type:focus_lowid:site:lead:contact

This section of the no_gen file gives the –generate command these instructions:

  • The first line generates a stop_if clause for cases when they are exported.
  • The second and third lines generate a specific unique key for gbst_elms.
  • With the fourth line, addresses will not be deleted from the database when exported.
  • The last line specifies an exclusive relation. The first four fields tell the generator that the participant object has an exclusive relation using the focus_type field for the object type and the focus_lowid field to act as the relation. These four fields are followed by an optional list of objects that the exclusive relation will point to – in this case, the site, lead, and contact.

Note: To add comments in the no_gen files, place the comments on a line preceded by a '#'.

See Also

Generating Purge/Archive Directives Files

To Generate a Purge/Archive Directives File

Sample Files Shipped with ArchiveManager

Next

Example no_gen File
no_gen File

Did this topic help you? Email us your feedback.
Last updated: 7/31/2007 2:25:05 PM


Example no_gen File

The following no_gen file can be used in a default Clarify database to generate a purge/archive directives file that archives similarly to the Clarify case.arc file.

case:stop_if:table_case t2::table_r_rqst t1::(t1.source_type = 0) and (t1.source_lowid=t2.objid)
case:stop_if:table_case t1::table_subcase t2::table_cls_factory t3::(t2.subcase2case=t1.objid) and (t3.factory2subcase=t2.objid)
case:stop_if:table_case t2::table_trans_record t1::(t1.trans_record2case=t2.objid)
case:stop_if:table_case t2::table_case t1::(t2.case_victim2case=t1.objid)
case:case2part_used:reference
case:caseinfo2demand_hdr:reference
subcase:subcase2cls_factory:reference
subcase:subcaseinfo2demand_hdr:reference
doc_inst:attach_info2doc_path:export
bug
probdesc
case:player2cas_cas_role
case:super2case
case:case_escal2escalation
case:case_info2fcs_detail
case:case_info2fcs_header
case:case_orig2job
case:case2r_rqst
case:chk_onhold2svc_intrup
case:case2trans_record
case:case2life_cycle
case:case_view2monitor
case:task2opportunity
case:case_rip2ripbin
subcase:aux_subcase2act_entry
subcase:subcase2escalation
subcase:subc_info2fcs_detail
subcase:subc_info2fcs_header
subcase:subcase2case
subcase:subcase2job
subcase:subc_view2monitor
subcase:subc_rip2ripbin
act_entry:act_entry2subcase
act_entry:act_entry2probdesc
act_entry:act_entry2workaround
act_entry:act_entry2notes_log
act_entry:act_entry2phone_log
act_entry:act_entry2resrch_log
act_entry:act_entry2commit_log
act_entry:act_entry2escalation
act_entry:act_entry2onsite_log
act_entry:act_entry2close_case
act_entry:act_entry2status_chg
act_entry:act_entry2svc_intrup
act_entry:act_entry2email_log
act_entry:act_entry2site_part
act_entry:act_entry2site
act_entry:act_entry2bug
act_entry:act_entry2close_bug
act_entry:act_entry2fix_bug
act_entry:act_xentry2subcase
act_entry:act_entry_child2parent
act_entry:act_entry_parent2child
act_entry:act_entry2biz_cal_hdr
act_entry:act_entry2schedule
act_entry:act_entry2disptchfe
act_entry:act_entry2employee
act_entry:act_entry2demand_dtl
act_entry:act_entry2todo
act_entry:act_entry2doc_inst
act_entry:act_entry2part_trans
act_entry:act_entry2to_do_entry
act_entry:act_entry2opportunity
act_entry:act_entry2contract
act_entry:act_entry2job
act_entry:act_entry2contact
act_entry:act_entry2module
act_entry:act_entry2task
act_entry:act_entry2exchange
act_entry:act_entry2exch_log
act_entry:act_entry2contr_itm
act_entry:entry2exch_timebomb
act_entry:act_entry2count_setup
act_entry:act_entry2case
act_entry:act_entry2reject_msg
participant:participant2act_entry
reject_msg:reject_reason2case
reject_msg:reject_reason2subcase
reject_msg:rej_reason2probdesc
reject_msg:reject_reason2bug
reject_msg:reject_msg2demand_dtl
reject_msg:reject_msg2opportunity
reject_msg:reject_msg2contract
reject_msg:reject_reason2job
reject_msg:reject_msg2task
reject_msg:reject_msg2dialogue
notes_log:case_notes2case
notes_log:subc_notes2subcase
notes_log:bug_notes2bug
notes_log:notes_log2bug_desc
notes_log:opp_notes2opportunity
notes_log:contr_notes2contract
notes_log:job_notes2job
notes_log:task_notes2task
notes_log:qq_notes2quick_quote
phone_log:case_phone2case
phone_log:subc_phone2subcase
phone_log:phone_log2condition
phone_log:opp_phone2opportunity
phone_log:task_phone2task
phone_log:contr_phone2contract
condition:case_condition2case
condition:subc_conditn2subcase
condition:cond_custsts2gbst_elm
condition:condition2probdesc
condition:bug_condition2bug
condition:condition2demand_dtl
condition:condition2contract
condition:opp_condition2opportunity
condition:job_condition2job
condition:task_condition2task
condition:condition2dialogue
workaround:solution2case
workaround:workaround2probdesc
workaround:workaround2act_entry
workaround:wa_attch2doc_inst
workaround:resolution2gbst_elm
workaround:workaround2template
resrch_log:case_resrch2case
resrch_log:subc_resrch2subcase
commit_log:commit_empl2employee
commit_log:bug_commit2bug
commit_log:opp_commit2opportunity
commit_log:job_commit2job
onsite_log:disfe_onsit2disptchfe
onsite_log:onsite_doer2employee
onsite_log:detail_onsite2demand_dtl
onsite_log:onsite_log2part_inst
onsite_log:onsite_log2exchange
status_chg:status_chg2bug
status_chg:status_chg2demand_dtl
status_chg:status_chg2opportunity
status_chg:job_status_chg2job
status_chg:contr_status_chg2contract
status_chg:status_chg2task
status_chg:status_chg2dialogue
email_log:bug_email2bug
email_log:old_email_stat2gbst_elm
email_log:new_email_stat2gbst_elm
email_log:contr_email2contract
email_log:opp_email2opportunity
email_log:cont_email2contact
email_log:task_email2task
doc_inst:attachment2workaround
doc_inst:doc_info2diag_hint
doc_inst:doc_inst2contract
doc_inst:doc_inst2site
doc_inst:doc_inst2site_part
doc_inst:doc_inst2act_entry
doc_inst:doc_inst2campaign
doc_inst:doc_inst2eco_hdr
doc_inst:doc_inst2eco_dtl
doc_inst:doc_inst2interact
doc_inst:doc_inst2demand_hdr
doc_inst:doc_inst2mod_level
doc_inst:doc_inst2bus_org
doc_inst:doc_inst2lit_req
doc_inst:doc_inst2lit_ship_req
doc_inst:doc_inst2opportunity
doc_inst:doc_inst2lead
doc_inst:doc_inst2contact
doc_inst:doc_inst2communication
doc_inst:doc_inst2template
disptchfe:disptchfe2onsite_log
disptchfe:disptchfe2fcs_detail
acd_call:acd_call_site2site
acd_call:acd_call_empl2user
scr_run:scr_run2contact
scr_run:scr_run2scr_response
scr_run:run_with2scr_run
scr_run:scr_run2campaign
scr_run:scr_run2lead_source
scr_run:scr_run2site_part
scr_run:scr_run2opportunity
scr_run:scr_run2contract
scr_run:scr_run2contr_itm
scr_run:scr_run2demand_dtl
scr_run:scr_run2site
scr_run:scr_run2task
scr_run:scr_run2bus_org
scr_run:scr_run2interact
scr_run:scr_run2lead
scr_response:response2scr_run
exchange:partner2site
exchange:exchange2act_entry
exchange:exchange2contract
exchange:exchange2onsite_log
exchange:exchange2exc_usr_role
exchange:exchange2exc_con_role
exchange:exchange2biz_cal_hdr
exchange:exchange2close_exch
exchange:exchange2exc_sit_role
exchange:exchange2exc_bch_role
exchange:last_close2close_exch
exch_log:exch_log2contact_role
exch_log:exch_log2user
exch_log:exch_log2close_exch
interact:interact2user
interact:interact2contact
interact:interact2lead_source
interact:interact2scr_run
interact:interact2mod_level
interact:interact2interact_txt
interact:member2interact
interact:interact2opportunity
hint_inst:hint_logic2prog_logic
workaround:Unique_field:id_number
workaround:Unique_relation:workaround2probdesc
wipbin:Unique_Field:title
wipbin:Unique_Relation:wipbin_owner2user
gbst_elm:Unique_Field:title
gbst_elm:Unique_Relation:gbst_elm2gbst_lst
participant
employee:Unique_Relation:employee2user
scrqstn_rspns:unique_field:seq_num
appointment:appt2schedule:export
schedule:no_delete
schedule:schedule2act_entry
doc_path:no_delete
demand_hdr:Unique_Field:header_number
script_qstn:Unique_Field:seq_num
script_qstn:Unique_Relation:question2call_script
hint_inst:hint_info2diag_hint:export
diag_hint:no_delete
case:case2address:export
address:no_delete
address:primary_addr2site
address:ship_addr2site
address:bill_addr2site
address:address2time_zone
address:address2country
address:address2state_prov
address:address2bus_addr_role
address:addr2site_addr_role
address:address2per_addr_role
address:bill_addr2contr_schedule
address:ship_addr2contr_schedule
address:bus_primary2bus_org
address:bill_addr2contr_itm

See Also

no_gen File

Common Objects that Need Unique Keys

Next

Common Objects that Need Unique Keys
Example no_gen File

Did this topic help you? Email us your feedback.
Last updated: 8/1/2007 9:08:55 AM


Common Objects that Need Unique Keys

These objects commonly need the following unique keys added to the no_gen file.

Object Type | Unique Fields | Unique Relations | Notes
gbst_elm | title | gbst_eln2gbst_lst |
employee |  | employee2user |
wipbin | title | wipbin_owner2user |
address | address,address_2, city, state, zipcode |  |
Participant |  |  | The participant object should not have a unique key, and it should export completely. Delete the reference_act_entry _through routine.
scr_run | title |  |
demand_dtl | detail_number |  |
demand_hdr | header_number |  |
price_prog | name |  |
scrqstn_rspns | seq_num | current2script_qstn |
script_qstn | seq_num | question2call_script |
workaround | id_number |  |

See Also

no_gen File

Example no_gen File

Next

Sample Files Shipped with ArchiveManager
Common Objects that Need Unique Keys

Did this topic help you? Email us your feedback.
Last updated: 11/6/2007 12:48:16 PM


Sample Files Shipped with ArchiveManager

The following files are shipped with ArchiveManager to help explain the purge/archive directives file generation process:

File | Purpose
case.no_gen | A no_gen file that generates a case purge/archive directives file similar to the one provided by Clarify.
gen_case.arc | The case purge/archive directives file generated by the case.no_gen file on MSSQL Clarify version 9.0.
clarify_case.arc | The Clarify case.arc file (Version 9.0 for MSSQL) with unique objids edited out.
site.no_gen | A no_gen file that generates a site purge/archive directives file similar to the one provided by Clarify.
gen_site.arc | The site purge/archive directives file generated by the site.no_gen file on MSSQL Clarify version 9.0
clarify_site.arc | The Clarify site.arc file (Version 9.0 for MSSQL) with unique objids edited out.
contact.no_gen | A no_gen file that generates a contact purge/archive directives file similar to the one provided by Clarify.
gen_ contact.arc | The contact purge/archive directives file generated by the contact.no_gen file on MSSQL Clarify version 9.0.
clarify_contact.arc | The Version 9.0 for MSSQL file with the unique objids edited out.

See Also

Generating Purge/Archive Directives Files

To Generate a Purge/Archive Directives File

no_gen File

Next

Updating the Checksum
Sample Files Shipped with ArchiveManager

Did this topic help you? Email us your feedback.
Last updated: 11/6/2007 12:34:06 PM


Updating the Checksum

After altering a purge/archive directives file, you must update the checksum in order to use the file during a purge or archive operation.

To update the checksum

  1. If a checksum does not already exist for the file, add this comment at the top of the purge/archive directives file:

    /* THE CHECKSUM FOR THIS FILE IS: 68B8 */
  2. From a command line, use the -checksum command parameter to update a purge/archive directives file. For example:

    diet -archive -directive gen_case.arc -checksum 123456AA

    In this example, a new checksum will be generated for the gen_case.arc file, and the archive will not be run.

    Note: To use the -checksum parameter, you must have write permission to the file. This permission requirement prevents any unauthorized creation of purge/archive directives files.

See Also

Purge/Archive Directives Files

Generating Purge/Archive Directives Files

Common Purge/Archive Directives Elements

Complete List of Purge/Archive Directives Elements

Recursively Deleting Objects

Example Purge/Archive Directives File

Example Purge/Archive Directives File with Routines

Next

Common Purge/Archive Directives Elements
Updating the Checksum

Did this topic help you? Email us your feedback.
Last updated: 12/13/2007 5:10:14 PM


Common Purge/Archive Directives Elements

Three elements are required for a purge/archive directives file to work: the export object, the actions, and a where clause. The where clause can either be in the purge/archive directives file or entered on the command line.

The basic export body in ArchiveManager purge/archive directives files is in the form:

<uniques> <where> <actions> <stop_ifs> <tos>

This section describes required and common purge/archive directives elements. To see how these elements fit together, see the Example Purge/Archive Directives File included with this guide.

See Also

Purge/Archive Directives Files

Generating Purge/Archive Directives Files

Updating the Checksum

Complete List of Purge/Archive Directives Elements

Recursively Deleting Objects

Example Purge/Archive Directives File

Example Purge/Archive Directives File with Routines

Next

Export Object
Common Purge/Archive Directives Elements

Did this topic help you? Email us your feedback.
Last updated: 8/1/2007 9:26:56 AM


Export Object

EXPORT OBJECT <object type>

The export object is a required purge/archive directives file element. It defines which object types to export. For example, in this very simple purge/archive directives file below, only the modem and phone object types will be exported:

EXPORT OBJECT modem

where objid > 0

Actions = Export, Delete, Group

;

EXPORT OBJECT phone

where objid > 0

Actions = Export, Delete, Group

;

The EXPORT OBJECT line is followed by a description of how to run the purge/archive. This might include directive elements such as routines, uniques, where statements, actions, stop ifs, to clauses, or other directive elements.

See Also

Common Purge/Archive Directives Elements

Uniques

Where

Actions

Stop Ifs

To Clauses

Conditional To Clauses

Routines

Next

Uniques
Export Object

Did this topic help you? Email us your feedback.
Last updated: 7/31/2007 2:38:30 PM


Uniques

[UNIQUE_FIELDS = <field> [, <field>]…]

[UNIQUE_RELATIONS = <relation> [, <relation>]…]

The <uniques> definition is optional. It lists the fields and/or relations that form the object type's unique key. Use the <field> value to list one or more unique fields. Use the <relation> value to list one or more unique relations. Either one or both of the <uniques> values can be listed. If both are listed, the UNIQUE_FIELDS must be listed first.

If no unique information is specified for the object, no unique information will be generated in the export file. If the object is a reference and no unique keys are defined or found in the database, an error will be generated.

See Also

Common Purge/Archive Directives Elements

Export Object

Where

Actions

Stop Ifs

To Clauses

Conditional To Clauses

Routines

Next

Where
Uniques

Did this topic help you? Email us your feedback.
Last updated: 7/31/2007 2:39:15 PM


Where

[WHERE = <string>]

The <where> definition is required for the purge/archive directives file to work. It must either be in the purge/archive directives file or entered on the command line. If –where is used on the command line, its <string> value will replace the <string> value defined in the purge/archive directives file.

The <string> value is an SQL search clause that defines what objects of this object type to find. For this to work, all data must be in the format of the SQL search. Examples:

WHERE objid > 0

WHERE "title like '%failure%'"

Note: If the clause contains single quotes it must be entirely enclosed in double quotes.

Note: When dealing with Unicode string constants, you must precede all Unicode strings with a capital letter N. For example, "WHERE title = N'résumé'"

See Also

Common Purge/Archive Directives Elements

Export Object

Uniques

Actions

Stop Ifs

To Clauses

Conditional To Clauses

Routines

Next

Actions
Where

Did this topic help you? Email us your feedback.
Last updated: 1/5/2011 5:13:00 PM


Actions

[ACTIONS = <action> [,<action>]…]

The <actions> definition is a required purge/archive directives file element. It defines the actions to take.

The <action> value can be EXPORT, DELETE, EXPORT_REF, and/or GROUP.

  • EXPORT – The object is exported as an object from the database. It will be listed as an OBJECT in the export file.
  • DELETE – The object is deleted from the database when the purge is complete. This action is usually paired with EXPORT.

    Note: No objects will be deleted during an archive. ArchiveManager will only honor the DELETE action during a purge.

  • EXPORT_REF – The object is exported as a reference from the database. It will be listed as a REFERENCE in the export file. EXPORT_REF cannot be paired with DELETE.
  • GROUP – The data at that level and below is exported as a single transaction. The data will maintain this grouping in the export file, so that it can be reimported as a single transaction.

See Also

Common Purge/Archive Directives Elements

Export Object

Uniques

Where

Stop Ifs

To Clauses

Conditional To Clauses

Routines

Next

Stop Ifs
Actions

Did this topic help you? Email us your feedback.
Last updated: 12/13/2007 5:10:30 PM


Stop Ifs

[STOP_IF <string>]…

The <stop_if> definition is optional. Use the <stop_if> element as a mechanism to stop an object's or an object type's export if the SQL expression evaluates to true. The SQL expression is defined with the <string> value. If the expression evaluates to true when checked, the purge/archive operation will stop the export and move on to the next top level object.

See Also

Common Purge/Archive Directives Elements

Export Object

Uniques

Where

Actions

To Clauses

Conditional To Clauses

Routines

Next

To Clauses
Stop Ifs

Did this topic help you? Email us your feedback.
Last updated: 7/31/2007 2:41:48 PM


To Clauses

[TO <object> [THROUGH <relation>] <to_body> END_TO]

[TO_EXCLUSIVE <object_field> THROUGH <relation_field> <to_body> END_TO]

The TO clause is optional. Use the TO clause to define the related object types to export. The related object is specified with the <object> value. The <relation> value can be a traditional relation value, such as case2subcase, or it can be a long integer field on the object that is used as a relation, such as the site_objid field on the site_part object.

Use the TO_EXCLUSIVE clause to export objects through an exclusive relation, which uses the object type id <object_field> and the objid <relation_field> as the exclusive relation parameters.

The <to_body>, used for both the TO and TO_EXCLUSIVE clauses, is in the form:

<uniques> <actions> <stop_ifs> <tos>

All object types related to the top level object type can be reached recursively and exported, and references can be pulled and included in the export file. In the example below, the case objects will be exported along with the related subcases. In addition, the activity logs for the cases and subcases will be exported.

EXPORT CASE

WHERE arch_id = 1

ACTIONS = EXPORT,DELETE

TO subcase through case2subcase

ACTIONS = EXPORT,DELETE

TO act_entry THROUGH subcase2act_entry

ACTIONS = EXPORT,DELETE

END_TO

END_TO

TO act_entry THROUGH case_act2act_entry

ACTIONS = EXPORT,DELETE

END_TO

See Also

Common Purge/Archive Directives Elements

Export Object

Uniques

Where

Actions

Stop Ifs

Conditional To Clauses

Routines

Next

Conditional To Clauses
To Clauses

Did this topic help you? Email us your feedback.
Last updated: 7/31/2007 2:43:46 PM


Conditional To Clauses

IF (expression) <to_clause>

[ELSEIF (expression) <to_clause>]….

[ELSE <to_clause>]

To use the TO clause conditionally based on the data in an object, use the IF/ELSEIF/ELSE element.

If the condition of the (expression) is true, the TO clause will be executed. The (expression) value is an equivalency in the form:

<field> = <value>

The <field> value is the object field, and <value> can be any integer, real number, or string that the <field> can match. The <value> can also be a table type id in the form:

<field> = TABLE <table>

The <table> value is the table type.

In the example below, the object being evaluated is called the participant. In this case, the participant object is a Clarify object that contains an exclusive relation that can go to a site, subcase, contact, or some other object type. The field focus_type points to the object type being related to, and the field focus_lowid is the relation to that object. A possible result of this clause: If the expression ( focus_type = TABLE (subcase) ) evaluates to true, the routine reference_site_through will run.

IF ( focus_type = TABLE(site) ) reference_site_through (focus_lowid)

ELSEIF ( focus_type = TABLE (subcase) ) reference_subcase_through(focus_lowid)

ELSEIF ( focus_type = TABLE (contact) ) reference_contact_through (focus_lowid)

ELSE TO_EXCLUSIVE focus_type THROUGH focus_lowid

ACTIONS = EXPORT_REF

END_TO

See Also

Common Purge/Archive Directives Elements

Export Object

Uniques

Where

Actions

Stop Ifs

To Clauses

Routines

Next

Routines
Conditional To Clauses

Did this topic help you? Email us your feedback.
Last updated: 7/31/2007 2:46:48 PM


Routines

Routines allow directives definitions to be reused. Once a definition has been written in a routine, it does not have to be written again – it can be called anywhere else within the directive file body. Routines make the directives code more readable and reusable. For a full example, see the Example Purge/Archive Directives File with Routines included with this guide.

The routine form:

[ROUTINE <routine name> <export body> END_ROUTINE]

Use the <routine name> value to name the routine. Enter the directives definitions in the <export body>. In the example below, the routine is named TO_ACT_ENTRY_THROUGH, and the export body is comprised of a to clause.

ROUTINE TO_ACT_ENTRY_THROUGH

TO act_entry THROUGH $1

ACTIONS = EXPORT,DELETE

END_TO

END_ROUTINE

To call a routine somewhere else in the directive file body, use the form:

<name> (parameters)

The <name> value specifies which routine to call. For the (parameters) value, list one or more parameters that can be passed to the routine being called. For example:

to_act_entry_through (subcase2act_entry)

Within the routine being called, the parameters being passed to it can be accessed using the $<number> substitution, where <number> refers to the order the parameters are listed. So, $1 would call the first parameter, $2 would call the second parameter, and so on.

In the following example, the routines TO_SUBCASE_THROUGH and TO_ACT_ENTRY_THROUGH are called in the EXPORT OBJECT body. When the routine TO_SUBCASE_THROUGH is called, case2subcase will be substituted for the $1. When the routine TO_ACT_ENTRY_THROUGH is called, case_act2act_entry will be substituted for the $1.

EXPORT OBJECT case

WHERE arch_id = 1

ACTIONS = EXPORT,DELETE

TO_SUBCASE_THROUGH(case2subcase)

TO_ACT_ENTRY_THROUGH(case_act2act_entry)

ROUTINE TO_SUBCASE_THROUGH

TO subcase THROUGH $1

ACTIONS = EXPORT,DELETE

TO_ACT_ENTRY_THROUGH(subcase2act_entry)

END_TO

END_ROUTINE

ROUTINE TO_ACT_ENTRY_THROUGH

TO act_entry THROUGH $1

ACTIONS = EXPORT,DELETE

END_TO

END_ROUTINE

See Also

Common Purge/Archive Directives Elements

Export Object

Uniques

Where

Actions

Stop Ifs

To Clauses

Conditional To Clauses

Next

Complete List of Purge/Archive Directives Elements
Routines

Did this topic help you? Email us your feedback.
Last updated: 7/31/2007 2:51:43 PM


Complete List of Purge/Archive Directives Elements

This is a complete list of the purge/archive directives elements that can be used in the directive file.

Purge/Archive Directives Elements | Values
action | := DELETE := EXPORT := EXPORT_REF := GROUP
action_list | := action , action_list := action
actions | := ACTIONS action_list := NULL
conditional_to | := IF (<expression>) <to_header> [ELSEIF (<expression>) <to_header>] + [ELSE <to_header>]
<expression> | := <field> = <integer> := <field> = <string value> := <field> = <float value> := <field> = TABLE(<object_type>)
export_body | := uniques where actions stop_ifs tos
export_list | := export_object , no_export_list := ALL , no_export_list := export_object := ALL
export_object | := <object_type> := <object_type> export_body
field_list | := <field> , field_list := <field>
no_export_list | := <object_type> , no_export_list := ALL , no_export_list := <object_type> := ALL
parameters | := <parameter> , parameters := <parameter>
relation_list | := <relation> , relation_list := <relation>
routine_call | := <routine_name> := <routine_name> ( parameters )
statement | := EXPORT OBJECT export_list ; := NO_EXPORT OBJECT no_export_list; := ROUTINE <routine_name> export_body END_ROUTINE ;
statements | := statement statements := NULL
stop_if | := STOP_IF <string> := <parameter>
stop_ifs | := stop_if stop_ifs := NULL
to | := to_header to_body END_TO := routine_call := conditional_to
tos | := to tos := NULL
to_body | := uniques actions stop_ifs tos
to_header | := TO <object_type> THROUGH <relation> := TO <object_type> THROUGH <parameter> := TO_EXCLUSIVE <object_field> THROUGH <relation_field>
unique_fields | := UNIQUE_FIELDS = field_list
unique_relations | := UNIQUE_RELATIONS = relation_list
uniques | := unique_fields := unique_fields unique_relations := unique_relations := NULL
where | := WHERE <string> := WHERE <string> <operator> <string> := WHERE <parameter> := NULL

See Also

Purge/Archive Directives Files

Generating Purge/Archive Directives Files

Updating the Checksum

Common Purge/Archive Directives Elements

Recursively Deleting Objects

Example Purge/Archive Directives File

Example Purge/Archive Directives File with Routines

Next

Recursively Deleting Objects
Complete List of Purge/Archive Directives Elements

Did this topic help you? Email us your feedback.
Last updated: 11/6/2007 12:35:56 PM


Recursively Deleting Objects

It is possible to recursively delete objects from a database with ArchiveManager.

For example, to recursively delete all of a case's children cases, make the following changes to the case.arc file:

  • Make most of the case body into a routine that can be recursively called.
  • Modify the case body to call itself.
  • Remove the stop_if that prevents the case object from being archived when it has a child case.

For an example of a file with these changes, see the recursive_case.arc file shipped with ArchiveManager. It is a modified clarify_case.arc file.

See Also

Purge/Archive Directives Files

Generating Purge/Archive Directives Files

Updating the Checksum

Common Purge/Archive Directives Elements

Complete List of Purge/Archive Directives Elements

Example Purge/Archive Directives File

Example Purge/Archive Directives File with Routines

Next

Example Purge/Archive Directives File
Recursively Deleting Objects

Did this topic help you? Email us your feedback.
Last updated: 8/1/2007 9:27:01 AM


Example Purge/Archive Directives File

/* THE CHECKSUM FOR THIS FILE IS: 6AAD     */
/* sccsid = @(#)period_amt.arc  1.5 05/11/98 15:43:51 */
/* period_amt archive directives file */
/* This file is intended for Clarify 6.0 databases */

NO_EXPORT OBJECT ALL;

EXPORT OBJECT period_amt

  UNIQUE_FIELD = "objid"

  WHERE  arch_ind = 1

  ACTIONS = GROUP, EXPORT, DELETE

TO amort_dtl THROUGH period_amt2amort_dtl

  UNIQUE_FIELD = "objid"

  ACTIONS = EXPORT, DELETE

END_TO

TO contr_itm THROUGH period2contr_itm

  UNIQUE_FIELD = "objid"

  ACTIONS = EXPORT_REF

END_TO

TO contr_schedule THROUGH period2contr_schedule

  UNIQUE_FIELD = "objid"

  ACTIONS = EXPORT_REF

END_TO

/*---------------end of period_amt directives--------------------*/

;

See Also
Purge/Archive Directives Files
Generating Purge/Archive Directives Files
Updating the Checksum
Common Purge/Archive Directives Elements
Complete List of Purge/Archive Directives Elements
Recursively Deleting Objects
Example Purge/Archive Directives File with Routines

Next
Example Purge/Archive Directives File with Routines

 Example Purge/Archive Directives File

            Did this topic help you? Email us your feedback.

Last updated: 11/6/2007 12:48:51 PM


Example Purge/Archive Directives File with Routines

Export Object period_amt period_amt_body;

Routine exporting_period_amt_through

        To period_amt Through $1

                period_amt_body

        End_To

End_Routine

Routine reference_contr_pr_through

        To contr_pr Through $1

                Unique_Field = objid

                Actions = Export_Ref

        End_To

End_Routine

Routine reference_contr_itm_through

        To contr_itm Through $1

                Unique_Field = objid

                Actions = Export_Ref

        End_To

End_Routine

Routine reference_contr_schedule_through

        To contr_schedule Through $1

                Unique_Field = objid

                Actions = Export_Ref

        End_To

End_Routine

Routine reference_trans_record_through

        To trans_record Through $1

                Unique_Field = objid

                Actions = Export_Ref

        End_To

End_Routine

Routine period_amt_body

        Unique_Field = objid

        Where $1

        Actions = Export, Delete, Group

        exporting_amort_dtl_through (period_amt2amort_dtl)

        reference_contr_schedule_through  (period2contr_schedule)

        reference_contr_itm_through  (period2contr_itm)

End_Routine

Routine exporting_amort_dtl_through

        To amort_dtl Through $1

                Unique_Field = objid

                Actions = Export, Delete

                reference_contr_pr_through  (amort_dtl2contr_pr)

                reference_period_amt_through  (amort_dtl2period_amt)

                reference_contr_itm_through  (amort_dtl2contr_itm)

                reference_contr_schedule_through  (detail2contr_schedule)

                reference_trans_record_through  (detail2trans_record)

        End_To

End_Routine

See Also
Purge/Archive Directives Files
Generating Purge/Archive Directives Files
Updating the Checksum
Common Purge/Archive Directives Elements
Complete List of Purge/Archive Directives Elements
Recursively Deleting Objects
Example Purge/Archive Directives File

Next
Export Directives Files

 Example Purge/Archive Directives File with Routines

            Did this topic help you? Email us your feedback.

Last updated: 11/6/2007 12:48:56 PM


Export Directives Files

Export directives files define the objects to export and not export from the database. The archived export files use a file syntax that is backwards compatible with Clarify's Dataex product. Export directives files only specify which objects to export and/or not export.

See Also

Directives Files

Purge/Archive Directives Files

Next

Export Directives File Description
Export Directives Files

Did this topic help you? Email us your feedback.
Last updated: 8/1/2007 9:28:23 AM


Export Directives File Description

The export can send out a single table, several tables, or all objects in the database. Unlike the purge and archive functions, it is not possible to export a subset of objects with complex SQL. No objects are deleted from the database in this process. The objects are exported into a data file which is defined with the –export command parameter, and they are sent in a format that both ArchiveManager and Dataex can read.

Export directives files cannot be created with the –generate command and do not require a checksum.

The export directives file only specifies which objects to export and/or not export:

EXPORT OBJECT <object type> [,<object type>]….;

And/Or

NO_EXPORT OBJECT <object type> [,<object type>]….;

The EXPORT OBJECT directive will export the specified object types. For example, only the rule objects will be exported with the following directive:

EXPORT OBJECT rule;

The NO_EXPORT OBJECT directive is only needed with the "EXPORT OBJECT ALL;" directive. In the next example, all table objects are exported (ALL), except for site_part, gbst_lst, and gbst_elm:

EXPORT OBJECT ALL;

NO_EXPORT OBJECT site_part, gbst_lst, gbst_elm;

See Also

Export Directives Files

Export Directives Elements

Next

Export Directives Elements
Export Directives File Description

Did this topic help you? Email us your feedback.
Last updated: 8/1/2007 9:28:26 AM


Export Directives Elements

This is a complete list of the export directives elements that can be used in the export directives file.

Export Directives Elements | Value
object_list | := <object type> , object_list := ALL , object_list := <object type> := ALL
statement | := EXPORT OBJECT object_list ; := NO_EXPORT OBJECT object_list ;
statements | := statement statements := NULL

See Also

Export Directives Files

Export Directives File Description

Next

Additional Notes
Export Directives Elements

Did this topic help you? Email us your feedback.
Last updated: 11/6/2007 12:37:01 PM


Additional Notes

This section contains additional ArchiveManager notes.

In This Chapter

Return Codes

Date Format Handling

Relinking ArchiveManager for Oracle

Recommended Clarify Directives File Edit

Next

Return Codes
Additional Notes

Did this topic help you? Email us your feedback.
Last updated: 8/1/2007 9:27:05 AM


Return Codes

ArchiveManager uses standard return codes:

  • zero (0) – The program has completed successfully.
  • one (1) – The program has encountered an error, a fatal error, or a usage error.

See Also

Additional Notes

Date Format Handling

Relinking ArchiveManager for Oracle

Recommended Clarify Directives File Edit

Next

Date Format Handling
Return Codes

Did this topic help you? Email us your feedback.
Last updated: 8/1/2007 9:27:08 AM


Date Format Handling

The date format can be set in several ways, listed below. The list is ordered from high to low priority – the top item will be honored above the one below it and so on. The date format can be set:

  • In the import file with the DATE_FORMAT <string> keyword. Place the keyword above all import file objects.
  • With the command line parameter –date_format <string>.
  • In the clarify.env file.
  • With the environmental variable DIET_DATE.
  • By appending the CLARIFY_DATE and CLARIFY_TIME environment variables.

The date format is similar to UNIX time formatting:

  • %y : two digit year */
  • %d : two digit day
  • %D : %m/%d/%y
  • %e : simple day
  • %H : 24 hour two digit hour
  • %I : 12 hour two digit hour
  • %k : 24 hour simple hour
  • %l : 12 hour simple hour
  • %m : two digit month
  • %M : two digit minute
  • %n : newline
  • %p : am/pm
  • %R : %H:%M
  • %S : second
  • %t : tab
  • %T : %H:%M:%S
  • %Y : four digit year
  • %yyyy : four digit year

For example, the time format '%d/%m/%Y %H:%M:%S' matches '3/10/2000 21:45:12'.

To turn off date format warnings, use the –date_quiet command parameter.

See Also

Additional Notes

Return Codes

Relinking ArchiveManager for Oracle

Recommended Clarify Directives File Edit

Next

Relinking ArchiveManager for Oracle
Date Format Handling

Did this topic help you? Email us your feedback.
Last updated: 7/30/2007 4:59:23 PM


Relinking ArchiveManager for Oracle

The first time ArchiveManager is run for Oracle, a library loading error may be issued. The libraries used to build ArchiveManager are operating system specific and database version specific. If this error is issued, relink ArchiveManager with the system libraries.

To relink libraries:

Run the command relink.oracle, a UNIX shell command script. The command will then ask questions about the Oracle Libraries:

  • What is the directory for the Oracle PRO*C library?
    Enter the directory where the Oracle libraries are stored. The Oracle client PRO*C compiler must be loaded on the system so that the libraries are available.
  • What is the Oracle library? [ clntsh ]
    The Oracle library is most likely [ clntsh ]. If so, hit return. If not, enter the correct Oracle library.

Note: If this command fails, or if you have any questions about this process, contact Dovetail Software.

See Also

Additional Notes

Return Codes

Date Format Handling

Recommended Clarify Directives File Edit

Next

Recommended Clarify Directives File Edit
Relinking ArchiveManager for Oracle

Did this topic help you? Email us your feedback.
Last updated: 8/14/2007 4:46:03 PM


Recommended Clarify Directives File Edit

If using the Clarify-supplied directives files, we recommend editing the files' UNIQUE_FIELD lines so that the archive does not rely on objid as the unique key. To view sample files with this change, open the clarify_case.arc, clarify_contact.arc, or clarify_site.arc files that were shipped with ArchiveManager.

See Also

Additional Notes

Return Codes

Date Format Handling

Relinking ArchiveManager for Oracle

Next

Copyright Notice and Trademarks
Recommended Clarify Directives File Edit

Did this topic help you? Email us your feedback.
Last updated: 8/1/2007 9:27:13 AM


Copyright Notice and Trademarks

Copyright © 2010 Dovetail Software, Inc.
All rights reserved

Dovetail Software intends the information in this document solely for its licensees and to aid prospective customers in evaluating Dovetail Software products. Any other use is prohibited. Dovetail Software makes a written warranty to its licensees, as is stated in its written license agreement. Dovetail Software makes no warranty to any other party regarding the accuracy or usefulness of the information contained in this document. Dovetail Software reserves the right to modify the content of this document without obligation to notify any party. Dovetail Software is not liable for consequential or incidental damages.

Dovetail Software develops and supplies software and customizations to the following Clarify products: ClearSupport, ClearQuality, ClearHelpDesk, ClearContracts, Policies and Customers, ClearSales, ProductManager, ClearCallCenter, and ClearLogistics.

ManyDovetail Software products use the following Clarify tools: User Interface Editor, ClearBasic Exchange, Data Dictionary Editor, ClearBasic Batch, Data Exchange, Clarify Business Objects, RuleManager, eBusiness Framework, ClearBasic, and Clarify Low-Level API©.

Clarify, its product names, and tools are trademarks of Amdocs, which may include the following: AmdocsCRM, ClearConfigurator, SalesBasic, ClearConfigurator Workshop, Notifier, eSupport, Classification Engine, eOrder Routing Server, eResponse Manager, ClearEnterprise, Email Clerk, Email Manager, Traveler, e.link, Diagnosis Engine, and Flexible Deployment.

Copyright Notice and Trademarks

Did this topic help you? Email us your feedback.
Last updated: 12/14/2010 5:57:37 PM


Dovetail ArchiveManager


Did this topic help you? Email us your feedback.
Last updated: 10/4/2011 3:34:38 PM


Contents Index Search